AppSync: Postgres upgrade fails

요약: AppSync: Postgres upgrade fails

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Postgres is being upgraded per KB 000504125, and it fails to upgrade Postgres.

The appsync_dbupgrade.log will show:
 

Command.run(): C:\Users\userid\AppData\Local\Temp\2\011266.tmp\executeScriptTmp0.bat:stdout [Failure, exiting]
Command.complete(): process completed with exit code: 1


The pg_upgrade_utility.log will show:
 

command: xcopy /e /y /q /r "E:\EMC\AppSync\jboss\datastore\data/pg_clog" "E:\EMC\AppSync\NewDatastore\data/pg_clog\" >> "pg_upgrade_utility.log" 2>&1
Invalid drive specification
0 File(s) copied


Note: The pg_upgrade_utility.log located in %AppData% will be removed when clicking OK when the failed upgrade message is presented during the upgrade dialog. Therefor this file must be collected before clicking OK and existing the upgrade dialog.

Note: The AppSync database resides in a non-default location, the E: drive in this example.

원인

The trigger is a permission related issue for which the precise cause is not known.
The upgrade utility is being run as administrator and the user who is logged in when the upgrade utility is run as administrator via the right click method is a Domain administrator which exists in the local admin group which has full rights to the E: drive.

Regardless, should you use procmon to debug, you will find permission errors for the logged in user to the E: drive.

해결

Explicitly provide full administrative right to the E: drive for the specific user that is logged in when running the upgrade process.

해당 제품

AppSync

제품

AppSync
문서 속성
문서 번호: 000057208
문서 유형: Solution
마지막 수정 시간: 17 4월 2026
버전:  7
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.