AppSync: Error while adding email addresses to alert settings if the string is over 255 characters.

요약: When adding additional email addresses to alert settings for service plans we are getting this error:"org.hibernate.exception.DataException: could not execute statement."

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상



When adding additional email addresses to alert settings for service plans we are getting this error:"org.hibernate.exception.DataException: could not execute statement."            
 
Server logs:
 
02-13-2018 12:46:38.328 ERROR [default task-44] [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] [ServerName] [] ERROR: value too long for type character varying(255)
02-13-2018 12:46:38.328 ERROR [default task-44] [org.jboss.as.ejb3.invocation] [ServerName] [] WFLYEJxxxxx: EJB Invocation failed on component AWEntityServiceBean for method public com.emc.archway.datamodel.AWEntity

원인

While adding the recipients email address to the alert settings for the particular service plan (Ex : Appsync UI screen / copy management / filesystem / host name / object in the Alert Setting button). You cannot enter a list of email addresses longer than 255 Characters.
 
As per the logs it is exceeding the maximum character limit of 255 characters. So, the total number of char combined from many email address should be 255 characters or less than that.

AppSync only allows a maximum of 255 characters for this field.

해결

  • You can remove any not required user from the list and proceed.
  • You can add the new user to the DL which is already exists.
  •  Raise enhancement request if customer is not ready to do both

해당 제품

AppSync

제품

AppSync
문서 속성
문서 번호: 000057246
문서 유형: Solution
마지막 수정 시간: 17 4월 2026
버전:  5
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.