Connectrix: Cisco: 포트가 즉시 오류 비활성화 상태로 전환됩니다.
요약: 이 KB 문서에서는 Connectrix가 다음과 같은 문제에 대해 설명합니다. Cisco 포트가 즉시 Error disabled 상태로 전환됩니다.
이 문서는 다음에 적용됩니다.
이 문서는 다음에 적용되지 않습니다.
이 문서는 특정 제품과 관련이 없습니다.
모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.
증상
특정 경우에 TCAM(Ternary Content Addressable Memory) 메모리 사용을 유발하는 다중 포트 플랩
포트가 Error disabled 실행 중인 상태 no shutdown.
디바이스 로그인이 있는 경우 포트는 Error disabled 상태:
edge-(config-if)# no shutdown fc4/29: (error) Failed to Write to TCAM
ACL(액세스 제어 목록) 프로그래밍으로 인해 영역 활성화 또는 디바이스 로그인 실패가 발생합니다.
다음 syslog 메시지가 표시됩니다.
%ZONE-2-ZS_TCAM_SWITCHED_TO_SOFT_ZONING_MODE: %$VSAN 12%$ Switched to soft zoning : Reason: Hard zoning disabled
TCAM 항목을 검토했습니다.
show system internal acl tcam-usage TCAM Entries: ============= Region1 Region2 Region3 Region4 Region5 Region6 Mod Fwd Dir TOP SYS SECURITY ZONING BOTTOM FCC DIS FCC ENA Eng Use/Total Use/Total Use/Total Use/Total Use/Total Use/Total --- --- ------ ---------- --------- ------------ --------- --------- --------- 4 3 INPUT 239/19664 0/9840 35004/49136* 87/19664 0/0 0/0
그런 다음 다음 오류가 나타납니다.
show port internal event-history errors 12) Event:E_DEBUG, length:119, at 424487 usecs after Wed Oct 5 00:50:56 2016 [102] pi_fsm_port_attr_change_init: Ifindex (fc4/26)0x1199000, Err disabled event (PI_FSM_EV_ACL_MODE_PROG_FAILURE)0x23
다음에 대해 동일한 오류가 있습니다.
[102] pi_fsm_ac_cfg_wait_resp_rcvd: Ifindex (fc4/32)0x119f000, Err disabled (0x404e0005) event (PI_FSM_EV_ACL_MODE_PROG_FAILURE)0x23 due to acl mode failure [102] pi_fsm_ac_cfg_wait_resp_rcvd: Ifindex (fc4/27)0x119a000, Err disabled (0x404e0005) event (PI_FSM_EV_ACL_MODE_PROG_FAILURE)0x23 due to acl mode failure [102] pi_fsm_ac_cfg_wait_resp_rcvd: Ifindex (fc4/29)0x119c000, Err disabled (0x404e0005) event (PI_FSM_EV_ACL_MODE_PROG_FAILURE)0x23 due to acl mode failure
그리고 이를 위해:
show port internal event-history errors 12) Event:E_DEBUG, length:119, at 424487 usecs after Wed Oct 5 00:50:56 2016 [102] pi_fsm_port_attr_change_init: Ifindex (fc4/26)0x1199000, Err disabled event (PI_FSM_EV_ACL_MODE_PROG_FAILURE)0x23
다음에 대해 동일한 오류가 있습니다.
[102] pi_fsm_ac_cfg_wait_resp_rcvd: Ifindex (fc4/32)0x119f000, Err disabled (0x404e0005) event (PI_FSM_EV_ACL_MODE_PROG_FAILURE)0x23 due to acl mode failure [102] pi_fsm_ac_cfg_wait_resp_rcvd: Ifindex (fc4/27)0x119a000, Err disabled (0x404e0005) event (PI_FSM_EV_ACL_MODE_PROG_FAILURE)0x23 due to acl mode failure [102] pi_fsm_ac_cfg_wait_resp_rcvd: Ifindex (fc4/29)0x119c000, Err disabled (0x404e0005) event (PI_FSM_EV_ACL_MODE_PROG_FAILURE)0x23 due to acl mode failure
원인
Cisco 버그 CSCuw15428 FC 규모: TCAM 다시 쓰기 실패로 인해 포트 오류가 비활성화되었습니다.
TCAM 사용량이 거의 제한에 도달하고 공간이 없다고 불평하므로 ACL 프로그래밍이 실패합니다.
'show system internal acl tcam-usage' 1 1 INPUT 2506/13114 0/3290 65496/68786* 16/13114 0/0 0/0 1 1 OUTPUT 7/4077 0/1645 0/11469 0/4077 6/1651 9/1654
높은 값은 프로그래밍된 일부 중복 항목 때문입니다.
module-1# sh process acltcam fwd-engine 1 input match interface fc 1/15 | inc d80601 00442 44 0 136 d80601 d80601 0 12 - - - - - - - - - | 0 0 0 0 0 0 02802 44 0 136 d80601 d80601 0 12 - - - - - - - - - | 0 0 0 0 0 0 08282 bb 0 136 d80601 6e028d 0 12 - - - - - - - - - | 0 0 0 0 1 0 0854a bb 0 136 d80601 6e028d 0 12 - - - - - - - - - | 0 0 0 0 1 0 08562 bb 0 136 d80601 6e028b 0 12 - - - - - - - - - | 0 0 0 0 1 0 08563 bb 0 136 d80601 6e028b 0 12 - - - - - - - - - | 0 0 0 0 1 0
때때로, tcam-usage 값이 음수로 바뀝니다.
`show system internal acl tcam-usage` TCAM Entries: ============= Region1 Region2 Region3 Region4 Region5 Region6 Mod Fwd Dir TOP SYS SECURITY ZONING BOTTOM FCC DIS FCC ENA Eng Use/Total Use/Total Use/Total Use/Total Use/Total Use/Total --- --- ------ ---------- --------- ------------ --------- --------- --------- 3 3 INPUT 192/9824 0/0 -1126/-1126* 131/9824 0/0 0/0
버전 7.3.0 이상 릴리스에서는 음수 값 대신 예기치 않게 큰 값이 표시됩니다.
1 5 INPUT 598/9824 0/0 4294964129/4294964129* 523/9824 0/0 0/0
해결
수정:
NX-OS 6.2(17)로 업그레이드합니다.
해결:
해당 라인 카드를 다시 로드합니다.
추가 정보
식별된 인스턴스에서 스위치는 9710 @ 6.2.11c이고 해당 라인 카드는 DS-X9448-768K9(2/4/8/10/16Gbps 고급 FC 모듈)입니다.
해당 제품
Connectrix MDS-Series Firmware 6.X제품
Connectrix MDS-Series Firmware 6.X문서 속성
문서 번호: 000064407
문서 유형: Solution
마지막 수정 시간: 20 3월 2026
버전: 6
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.