NMM: Hyper-V 복원이 실패하고 "복구 프로그램을 시작하지 못했습니다" 오류가 표시됩니다.

요약: NMM(NetWorker Module For Microsoft) Hyper-V 복원이 실패합니다. NMM 클라이언트 UI에서 이미지 레벨 복구를 수행하는 계정에 대한 애플리케이션 관리자 권한이 없습니다.

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증상

NMM 소프트웨어를 통해 수행된 Hyper-V 복원이 실패하고 다음 오류 메시지가 생성됩니다.

Error Starting Restore
There was an unknown error while starting the recovery process. Please try again.
Failed to start the recover program

스크린샷:
복구 프로세스를 시작하는 동안 알 수 없는 오류가 발생했습니다.  

원인

Hyper-V 클라이언트 리소스의 "원격 사용자" 필드에 구성된 서비스 계정에 NetWorker Server에 대한 사용 권한이 부족합니다. 백업/복구 기능이 성공하려면 먼저 계정을 Application Administrators 사용자 그룹에 추가해야 합니다.

이 요구 사항은 "C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw" 로그에서 다음 메시지를 확인합니다.

NetWorker: nsr_render_log 사용하여 .raw 로그 파일을 렌더링하는 방법

76587 MM/DD/YYYY HH:MM:SS PM  5 1 13 3788 3188 0 hostname.fqdn nsrjobd SYSTEM critical User <SERVICE_ACCOUNT> does not have the privileges required to start the requested job. The required privilege is: Operate NetWorker. The job requested to be started is: nsrcscd. 
76587 MM/DD/YYYY HH:MM:SS PM  5 1 13 4376 3188 0 hostname.fqdn nsrjobd SYSTEM critical User <SERVICE_ACCOUNT> does not have the privileges required to start the requested job. The required privilege is: Operate NetWorker. The job requested to be started is: nsrsnap_vss_recover.exe.

해결

Hyper-V Client의 서비스 계정을 NetWorker Management Console의 애플리케이션 관리자 사용자 그룹에 추가합니다.

이는 NMC의 구성 > 사용자 그룹 > 애플리케이션 관리자 아래에서 찾을 수 있습니다.

도메인 명명된 계정이 추가된 애플리케이션 관리자의 스크린샷

참고: 때때로 account@domain format은 작동하지 않으며 대신 format을 사용해야 합니다. account@* 또는 account@<eachlocalhost> 보안 강화를 위해.

호스트 명명된 계정이 있는 랩의 애플리케이션 관리자 스크린샷

해당 제품

NetWorker, NetWorker Module for Microsoft

제품

NetWorker Family, NetWorker Module
문서 속성
문서 번호: 000067819
문서 유형: Solution
마지막 수정 시간: 17 3월 2026
버전:  5
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