비즈니스용 Dell SupportAssist가 설치된 경우 Dell.Genoa.Agent.exe 및 Dell.Genoa.UserProcess.exe의 CPU 사용량이 높은 문제를 해결하는 방법

요약: 비즈니스용 Dell SupportAssist가 Dell.Genoa.Agent.exe 및 Dell.Genoa.UserProcess.exe와 함께 설치된 경우 컴퓨터의 CPU 사용량이 높아질 수 있습니다.

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

영향을 받는 제품:

  • Dell Insights
  • 비즈니스용 Dell SupportAssist

영향을 받는 버전:

  • v2.1.4 이하

해당되는 플랫폼:

  • Windows 10

비즈니스용 Dell SupportAssist에는 Dell Insights라는 구성 요소가 포함되어 있습니다. Dell Insights는 관리자가 Dell TechDirect 콘솔 내에서 사용할 수 있도록 엔드포인트에서 다양한 텔레메트리 정보를 가져옵니다. 이 텔레메트리 데이터는 다양한 Windows 성능 카운터를 사용하여 가져오며 드물지만 이러한 성능 카운터가 손상될 수 있습니다. 이 문서에서는 이러한 카운터를 재설정하여 손상된 Windows 성능 카운터에서 발생할 수 있는 문제를 해결하는 방법에 대해 설명합니다.

원인

드문 경우지만 Windows 성능 카운터가 손상되어 Dell.Genoa.Agent.exe 또는 Dell.Genoa.UserProcess.exe 리소스가 많이 소모될 수 있습니다. 영향을 받는 컴퓨터는 Dell.Genoa.Agent.exe 또는 Dell.Genoa.UserProcess.exe 프로세스에서 높은 CPU 사용량을 보여줍니다. 높은 메모리 사용량(500MB 이상)도 원인입니다.

해결

Windows 성능 카운터를 플러시하여 해결할 수 있습니다. 데이터가 제대로 플러시되도록 다음 단계를 순서대로 수행해야 합니다. 하단의 .bat 파일에서 사용할 수 있는 예제 스크립트가 있습니다. 이 수동 실행과 관련된 질문이나 문제가 있는 경우 Dell ProSupport에 문의하십시오.

  1. Dell Insights Agent 서비스를 중지합니다.
    • 예제 구문: net stop DellInsightsAgent
  2. Windows 성능 카운터를 플러시합니다.
    • 예제 구문(32비트 운영 체제): C:\Windows\system32\lodctr.exe /R
    • 예제 구문(64비트 운영 체제): C:\Windows\syswow64\lodctr.exe /R
참고: 디바이스의 상태에 따라 lodctr을 두 번 실행해야 합니다. Dell은 WMI 성능 카운터를 실행하고 lodctr플러시한 다음 다시 실행하는 lodctr 것이 좋습니다. Windows 성능 카운터에 대한 자세한 내용은 https://support.microsoft.com/en-us/help/300956/how-to-manually-rebuild-performance-counter-library-valueshttps://docs.microsoft.com/en-us/windows-server/administration/windows-commands/lodctr 이 하이퍼링크는 Dell Technologies 외부의 웹사이트로 연결됩니다. 이 하이퍼링크는 Dell Technologies 외부의 웹사이트로 연결됩니다. 참조하십시오.
  1. WMI 성능 카운터를 플러시합니다.
    • 예제 구문: winmgmt.exe /resyncperf
  2. WMI 서비스를 재시작합니다.
    • 예제 구문: net stop Winmgmt /y
참고: WMI가 중지되면 가상 머신 관리 서비스, SCCM 및 IP 도우미 서비스를 비롯한 다른 여러 서비스도 중지될 수 있습니다. 수동으로 재시작해야 합니다. Windows 성능 카운터에 대한 자세한 내용은 https://support.microsoft.com/en-us/help/300956/how-to-manually-rebuild-performance-counter-library-values 이 하이퍼링크는 Dell Technologies 외부의 웹사이트로 연결됩니다.를 참조하십시오.
  1. Dell Insights의 기존 로그를 모두 제거합니다.
    • 예제 구문: RMDIR /s /q "C:\ProgramData\Dell\Dell Insights\"
  2. Re-Start the Dell Insights Agent service.
    • 예제 구문: net start DellInsightsAgent

예제 스크립트

::creating logging directory
mkdir C:\ProgramData\Dell\InsightsLogging\

::starting logging
ECHO "" >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log
ECHO Flushing Performance Counters >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log
ECHO %DATE%%TIME% >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log

:stopping Insights service
net stop DellInsightsAgent >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log

::killing process in case the service fails to stop (can happen when in a loop)
taskkill /im Dell.Genoa.Agent.exe /f >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log

::flushing performance counters
C:\Windows\system32\lodctr.exe /R >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log
C:\Windows\syswow64\lodctr.exe /R >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log
winmgmt.exe /resyncperf >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log

::stopping services
net stop Winmgmt /y >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log

::re-flushing to validate caches are truly flushed
C:\Windows\system32\lodctr.exe /R >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log
C:\Windows\syswow64\lodctr.exe /R >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log
winmgmt.exe /resyncperf >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log

::re-starting services
net start Winmgmt >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log
net start vmms >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log
net start CcmExec >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log
net start iphlpsvc >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log

::purging logs
RMDIR /s /q "C:\ProgramData\Dell\Dell Insights\" >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log

::re-starting insights agent
net start DellInsightsAgent >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log
참고: 이 스크립트는 C:\ProgramData\Dell\InsightsLogging\에 로깅 디렉토리를 만들고 FlushLogging.log라는 로그 파일을 출력합니다.
  • 관리자로 실행해야 합니다.
  • 프로세스 중에 각 라인 항목의 상태를 출력합니다. 
  • 모든 Windows 성능 카운터를 재설정합니다.
  • 비즈니스용 Dell SupportAssist의 일부인 Dell Insights Agent에 대한 기존 로그를 플러시합니다.

지원 부서에 문의하려면 Dell Data Security 국제 지원 전화번호를 참조하십시오.
온라인으로 기술 지원 요청을 생성하려면 TechDirect로 이동하십시오.
추가 정보 및 리소스를 보려면 Dell 보안 커뮤니티 포럼에 참여하십시오.

해당 제품

Dell Encryption
문서 속성
문서 번호: 000129424
문서 유형: Solution
마지막 수정 시간: 02 5월 2023
버전:  9
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.