Avamar: MCS 메시지 "getsockname failed: 잘못된 파일 설명자"

요약: MCS 메시지 "getsockname failed: 잘못된 파일 설명자"

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Avamar UI의 이벤트 관리에서 보고되는 오류는 다음과 같습니다.

error: getsockname failed: Bad file descriptor

Avamar 데이터 노드의 메시지 로그에서 찾을 수 있는 메시지는 다음과 같습니다.
less /var/log/messages

Oct  4 19:28:54 AvamarUtilityNode sshd[108141]: Invalid user MCUser from 192.xxx.x.x(Example)
Oct  4 19:28:54 AvamarUtilityNode sshd[108141]: input_userauth_request: invalid user MCUser
Oct  4 19:28:54 AvamarUtilityNode sshd[108141]: Failed keyboard-interactive/xxx for invalid user MCUser from 192.xxx.x.x(Example) port xxxx ssh2
Oct  4 19:28:54 AvamarUtilityNode sshd[108141]: Postponed keyboard-interactive for invalid user MCUser from 192.xxx.x.x(Example) port xxxx ssh2
Oct  4 19:28:54 AvamarUtilityNode sshd[108141]: error: xxx: User not known to the underlying authentication module for illegal user MCUser from 192.xxx.x.x(Example)
Oct  4 19:28:54 AvamarUtilityNode sshd[108141]: Failed keyboard-interactive/xxx for invalid user MCUser from 192.xxx.x.x(Example) port xxxx ssh2
Oct  4 19:28:54 AvamarUtilityNode sshd[108141]: Disconnecting: Too many authentication failures for MCUser
Oct  4 19:28:54 AvamarUtilityNode sshd[108141]: error: getsockname failed: Bad file descriptor

 

원인

가능한 원인은 다음과 같습니다

  • 암호를 테스트하는 네트워크 보안 검사
  • 스토리지 관리 소프트웨어가 MCUser 계정(예: "APTARE")을 사용하도록 잘못 구성되었습니다.

계정을 사용하여 Avamar Server에 SSH 요청을 하면 요청이 거부됩니다.
메시지는 오류를 나타내지 않습니다. 원인을 알고 있는 경우 무시할 수 있습니다.

 

해결

  1. SSH 요청의 소스 IP 또는 호스트 이름(/var/log/messages의 오류에서)을 찾습니다.

    1. 스크립트 또는 프로세스가 실행 중인지 확인합니다.
    2. 사용 중인 인증 방법을 확인합니다. Avamar OS에서는 MCUser 계정을 사용할 수 없습니다.
    3. 호스트를 찾을 수 없고 실행 중인 스크립트나 프로그램이 없다면 악의적인 것으로 간주할 수 있습니다. 침입을 제거하는 데 필요한 예방 조치를 취하십시오.
  2. Avamar Server에서 avfirewall 서비스를 설정하여 알 수 없는 IP 주소의 요청을 방지합니다. 자세한 내용은 Avamar Security Guide를 참조하십시오.

 

해당 제품

Avamar

제품

Avamar, Avamar Server
문서 속성
문서 번호: 000169666
문서 유형: Solution
마지막 수정 시간: 03 6월 2026
버전:  7
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.