Zwracanie wywołań RESTAPI trwa za długo, powodując błędy przekroczenia limitu czasu VSS w AppSync

요약: Zwracanie wywołań RESTAPI trwa za długo, powodując błędy przekroczenia limitu czasu VSS w AppSync

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Klient używa AppSync, który korzysta z RESTAPI w celu wykonania migawek na hostach Windows 2016. Używane jest rozwiązanie Microsoft VSS, które wymaga odpowiedzi w ciągu 10 sekund, a zapewnienie odpowiedzi przez RESTAPI trwa o wiele dłużej, nawet jeśli sesja snapvx zakończy się w mniej niż 1 sekundę.

W dziennikach AppSync widzimy zapytanie o migawkę, a zaraz potem widzimy rozpoczęcie tworzenia snapvx w dziennikach SYMAPI. Migawka jest wykonywana w mniej niż sekundę. Jednak zwrot z RESTAPI do AppSync nie występuje przez kolejne 30 sekund po ukończeniu tej operacji. W dziennikach SMAS i RESTAPI wyświetlą się poniższe informacje (wymagane jest rejestrowanie informacji w Unisphere):

INFO [em.bp.RESTAPIUSAGE] (default task-611) /private/91/replication/symmetrix/{symmetrixId}/snapshot/{snapshotName} AppSync/4.1.0.1_2492_R2/<adres_IP>    POST    36829 ms    201    null    null    null

원인

W tym przypadku ten problem pojawił się, gdy klient wykonywał migawki poszczególnych urządzeń, a nie na poziomie grupy pamięci masowej. Klient wykonywał migawki ponad 50 urządzeń, co przyczyniło się do wydłużenia czasu potrzebnego na zwrócenie zapytania RESTAPI z powrotem do AppSync. 

W celu obejścia tego problemu zespoły inżynierów opracowały zmianę architektury w celu dostosowania wywołań RESTAPI, aby odpowiadały w ciągu limitu czasu VSS wynoszącego 10 sekund

해결

Rozwiązanie: Dostępna jest poprawka do obejścia tego problemu. Istnieją poprawki zarówno dla Unisphere, jak i AppSync, które są wymagane do rozwiązania problemu. Prosimy skontaktować się z działem pomocy technicznej, odwołać się do tego artykułu z bazy wiedzyi poprosić o następujące poprawki:

- Unisphere for PowerMax 9.2.0.9
- Poprawka AppSync 4.1.0.1_2492_R3

Obie poprawki są wymagane do obejścia tego problemu.

해당 제품

Unisphere for PowerMax
문서 속성
문서 번호: 000182815
문서 유형: Solution
마지막 수정 시간: 06 11월 2025
버전:  6
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.