VxRail: 이벤트 VXR034018
요약: 이벤트 VXR034018 원격 연결을 활성화하지 못했습니다.
증상
증상 1
VxRail 8.x를 9.1.x로 업그레이드한 후 vCenter에서 다음과 같은 알람이 발생할 수 있습니다.
VXR034018 – Failed to enable Remote ConnectivityVXR034020 – Remote Connectivity Lost
원인 및 사용 가능한 해결 단계에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오. VxRail: VxRail 8.x를 9.1.000으로 업그레이드한 후 Dell 지원 시스템에 대한 연결이 끊어짐
증상 2
연결을 활성화하면 아래 오류가 표시됩니다.
그림 1. 연결 요청 활성화
자세한 오류 로그는 다음에서 찾을 수 있습니다. /var/log/microservice_log/short.term.log또는 마이크로 서비스 로그에 직접 로그인할 수 있습니다.
VxRail Manager가 7.0.350에서 실행 중인 경우: Vxm# docker service logs func_rcs-service
VxRail Manager가 7.0.370 이상 버전에서 실행 중인 경우:
Vxm# kubectl logs $(kubectl get pods -o=name | grep rcs)
원인
다음과 같은 여러 가지 문제로 인해 연결 활성화가 실패할 수 있습니다.
- 포트 443 및 8443을 통한 VxRail Manager와 Dell Enterprise Server 간의 네트워크 문제:
esrs3-core.emc.com
esrs3-coredr.emc.com
- SCG(Secure Connect Gateway) 서버 포트 번호를 잘못 입력했습니다. 포트 번호는 9443이어야 합니다.
그림 2. 포트 9443
- 액세스 키와 핀이 이미 사용되었습니다.
- 잘못된 액세스 키 및 PIN
- 범용 키가 만료되었거나 노드 PSNT가 Dell 백엔드에 등록되지 않았습니다.
- 범용 키가 유효한 JSON 형식이 아닙니다.
short.term.log파일로 교체합니다.
"2023-02-09 03:45:05,333" microservice.rcs-service "2023-02-09T03:45:05.308340848Z stderr F json.decoder.JSONDecodeError: Expecting property name enclosed in double quotes: line 1 column 2 (char 1)"
- 다음에서 Secure Remote Services로부터 응답이 수신되지 않음
short.term.log파일로 교체합니다.
2022-08-24-16:56:57 microservice.dell-ese "8 2022-08-24 16:56:57,881 CP Server Thread-5 DEBUG DellESE.ese.srs.srswebapi LN:1164 Calls universal device key api"
2022-08-24-16:56:58 microservice.dell-ese "8 2022-08-24 16:56:58,295 CP Server Thread-5 DEBUG urllib3.connectionpool LN: 939 Starting new HTTPS connection (1): esrs3-coredr.emc.com:443"
2022-08-24-16:56:58 microservice.dell-ese "8 2022-08-24 16:56:58,612 CP Server Thread-5 WARNING ESE.CherryPy LN:1138 Web exception during getUniversalKey api call: No response received from SRS"
2022-08-24-16:56:58 microservice.rcs-service "2022-08-24 16:56:58,614 [INFO] <ThreadPoolExecutor-0_3:140391562225408> ese_service.py generate_universal_key_by_pin() (359): Generate universal key response:500,{""message"": ""Web exception during getUniversalKey api call: No response received from SRS"", ""statusCode"": 500, ""backendResponse"": {}, ""status"": ""fail""}"
2022-08-24-16:56:58 microservice.api-gateway "169.254.171.104 - - 2022-08-24T16:56:58+00:00 ""POST /rest/vxm/internal/dell-ese/v1/ese/getUniversalKey HTTP/1.1"" 500 151 """" ""python-requests/2.24.0"" """""
2022-08-24-16:56:58 microservice.dell-ese "Back-end web error: Calls universal device key api Status: 500 - "해결
문제 1:
연결 유형이 직접 연결인 경우 VxRail Manager가 esrs3-coredr.emc.com 및 esrs3-core.emc.com 에 액세스해야 합니다. VxRail Manager에서 다음 명령을 실행합니다.
ping esrs3-coredr.emc.com
또는
curl -gvk https://esrs3-coredr.emc.com
연결 유형이 게이트웨이 서버를 통한 연결인 경우 KB VxRail: 자세한 내용은 VxRail 7.0.350 이상과의 차세대 연결을 참조하십시오.
문제 2:
포트 번호 9443을 SCG 게이트웨이 포트로 사용하고 VxRail Manager에서 포트 5700에 액세스할 수 있는지 확인합니다.
문제 3 및 4의 경우:
액세스 키 생성 에서 새 액세스 키와 PIN을 생성합니다.
그림 3. 액세스 키 생성
문제 5: Dell 지원 부서에 문의하여 KB Dell VxRail: "범용 키가 만료되었거나 노드 PSNT가 Dell 백엔드에 등록되지 않았습니다" 오류로 인해 연결을 활성화하지 못했습니다.
문제 6: Dell 지원에 문의하고 KB VxRail의 견적을 작성하십시오. 다음 오류와 함께 연결 활성화가 실패합니다. "요청 활성화 내부 오류입니다. KB 000193409 참조"
문제 7:
- 문제 1의 항목을 확인하고 직접 연결이 아닌 경우 사용자 인터페이스 또는 SSH에서 SCG 서버에 로그인하여 SCG가 응답하는지 확인합니다.
- 아래 샘플에 따라 IT 티켓을 열어 Dell 백엔드 응답을 확인합니다.
- IT 티켓을 연 후 KB ESE SupportAssist SCG를 따릅니다. 포괄적인 연결 팀을 참여 시켜 인시던트를 에스컬레이션하는 방법
오픈 IT 티켓 프로세스:
- 브라우저 - 안내 도움말 - My IT(service-now.com)
- 문제를 간략하게 설명합니다.
- 제품 ->Secure Remote Services IP SOLUTION 3.0
- Category ERROR ->오류 메시지
- 하위 범주 ERROR ->오류 메시지
- 문제 및 첨부 파일 로그, 스크린샷에 대한 세부 정보를 추가합니다.
- 감시 목록을 추가합니다.
- 아래 스크린 샷과 같은 티켓 샘플 :
그림 4. 샘플 티켓
문제 해결 후에도 문제가 지속되면 Dell 기술 지원 부서 또는 공인 서비스 담당자에게 문의하십시오.
추가 정보
- 네트워크 문제-프록시 서버, 고유 연결 키 적법성 문제와 같은 장애 요인은 제외합니다. 원격 커넥터 서비스 로그인을 확인합니다.
/var/log/microservice_log/short.term.log또는/home/mystic/ese/var/log/ESE.log. - ESE는 백엔드를 직접 연결하거나 SCG 게이트웨이를 사용하는 두 가지 시나리오를 지원합니다. 게이트웨이에서 문제가 발생한 경우 RSE는 관련 로그인을 확인할 수 있습니다.