VxRail: vCenter 오류 "ramdisk 'root'가 가득 찼습니다. 결과적으로 파일을 쓸 수 없습니다."

요약: vCenter가 호스트에 대한 오류를 표시함: "램디스크 '루트'가 꽉 찼습니다. 결과적으로 파일 *에 쓸 수 없습니다."

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

증상 1: Ramdisk의 루트는 100%입니다.
  • Putty를 사용하여 ESXi 호스트에 ssh를 실행합니다.
  • vdf -h
  • 루트가 100%로 표시되는지 확인합니다.
출력 예:
image.png
루트는 사용% 100%로 표시됩니다.

증상 2: ramdisk의 루트가 가득 찼으며 실행 시 다음 오류가 표시됩니다.
esxcli software vib list

다음으로 끝나는 오류가 표시됩니다.
"socket.error: [Errno 2] No such file or directory"
또는
로그 파일이 없거나 /var/log/에서 업데이트되지 않습니다.
또는
영향을 받는 ESXi 호스트에는 HA 에이전트를 설치할 수 없습니다.
 

원인

두 가지 가능한 원인:

1. 파일이 수동으로 호스트에 복사되고 잘못된 경로(즉, /vmfs/volumes 외부의 경로)가 사용되었습니다.
2. 영구적인 스크래치 공간을 사용할 수 없는 경우 ESXi는 이 임시 데이터를 ramdisk에 저장합니다. 이것은 공간에 제약이 있습니다. 이는 메모리 부족 상황에서 문제가 될 수 있지만 ESXi 작동에 중요하지는 않습니다. ramdisk에 저장된 정보는 재부팅 시 유지되지 않으므로 로그 및 코어 파일과 같은 문제 해결 정보가 손실될 수 있습니다. 호스트의 영구적인 스크래치 위치가 잘못 구성된 경우 임시 파일을 위한 공간이 부족하고 로그 파일이 업데이트되지 않아 간헐적인 문제가 발생할 수 있습니다.

해결

1. 파일 문제는 Broadcom KB: https://knowledge.broadcom.com/external/article?legacyId=2001550 를 검토하고 아래 단계를 따르십시오.
  • 관리자 작업으로 인해 오류가 발생한 경우 잘못된 경로를 사용하는 파일을 삭제하거나 데이터 저장소로 이동합니다.
또는
  • Putty를 사용하여 ESXi 호스트에 ssh를 실행합니다.
  • find / -size +1024k -exec du -h {} \; | less
  • 오래되거나 오래되어 남아 있는 ESXi 호스트 로그 번들을 이동하거나 삭제합니다.


2. 이 문제를 해결하려면 Broadcom KB: https://knowledge.broadcom.com/external/article?legacyId=1033696 를 검토하고 아래 단계를 따르십시오.
  1. Putty를 사용하여 ESXi 호스트에 ssh를 실행합니다.
  2. df -h
     image.png
  3. Mounted on 아래에 표시되는 Filesystem "VMFS-L"의 파일 경로에 주석을 추가합니다. 참고:  시작 부분에 'OSDATA-'가 없는 볼륨인 디렉토리로 이동하는 기호 링크입니다. 예를 들어 위 스크린샷의 정보를 사용하여 VMFS-L이 '마운트된 위치' 파일 경로는 '/vmfs/volumes/OSDATA-604f7166-b35be91f-0d4c-005056281a17'로 표시됩니다.image.png
  4. vCenter에 로그인합니다.
  5. 해당하는 호스트를 클릭합니다.
  6. Configure > SystemAdvanced > System Settings로 이동합니다.
  7. 'scratchconfig'에 대한 키를 필터링합니다.
  8. 찾으세요 
    'ScratchConfig.ConfiguredScratchLocation'.
  9. 3단계의 파일 경로를 "OSDATA-"를 사용하지 않고 삽입합니다. 예:
    '/vmfs/volumes/OSDATA-604f7166-b35be91f-0d4c-005056281a17' should be entered as '/vmfs/volumes/604f7166-b35be91f-0d4c-005056281a17'.
  10. 호스트를 유지 보수 모드로 전환하고 호스트를 재시작합니다.
  11. 호스트가 재시작되면 vCenter에 로그인하여 확인합니다
    'ScratchConfig.ConfiguredScratchLocation' AND 'ScratchConfig.CurrentScratchLocation'
    이 9단계에서 추가한 올바른 디렉토리 경로를 표시합니다.

해당 제품

VMware ESXi 6.7.X, VMware ESXi 7.x, VMware ESXi 8.x
문서 속성
문서 번호: 000193942
문서 유형: Solution
마지막 수정 시간: 12 5월 2026
버전:  4
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.