오픈시프트: 노드가 준비되지 않았거나 예약이 비활성화된 OCP 업그레이드 사후 검사 오류
요약: 라이브 마이그레이션할 수 없는 RWO(ReadWriteOnce) 스토리지 볼륨으로 구성된 VM으로 인해 노드가 준비되지 않았거나 예약이 비활성화된 OCP 업그레이드 사후 검사 오류입니다.
이 문서는 다음에 적용됩니다.
이 문서는 다음에 적용되지 않습니다.
이 문서는 특정 제품과 관련이 없습니다.
모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.
증상
OCP 업그레이드 사후 검사 프로세스 중에 "OCP 클러스터에 대한 사후 검사를 실행하지 못했습니다. 노드가 준비되지 않았거나 예약이 비활성화되었습니다."
원인
오류 보고 노드에서 실시간 마이그레이션할 수 없는 RWO(ReadWriteOnce) 스토리지 볼륨으로 구성된 하나 이상의 VM입니다.
가상 머신 디스크의 스토리지 볼륨에 대한 자세한 내용은 아래의 Openshift 문서를 참조하십시오.
해결
1. VM PV 설정을 변경합니다.
2. 상태가 "Ready,SchedulingDisabled"인 노드를 찾습니다.
3. 노드를 드레이닝하여 실행 중인 포드를 제거합니다.
4. 디버그 모드를 설정하고 노드를 재부팅합니다.
5. 재부팅 후 노드가 준비되면 예약 가능으로 표시합니다.
6. 노드가 예약 가능으로 표시되었는지 확인합니다.
- 1.1PV 설정을 변경하기 전에 VM 인스턴스를 중지합니다.
- 1.2 VM을 클릭하고 YAML 탭으로 전환
- 1.3 accessModes 를 "ReadWriteOnce"에서 "ReadWriteMany"로 변경
- 1.4 PV를 ReadWriteMany로 설정할 수 없는 경우(VM에서 ReadWriteMany를 사용할 수 없음) LiveMigrate에서 evictionStrategy를 None으로 설정합니다.
참고: 환경에 적용되는 1.3단계 또는 1.4단계를 수행합니다. 두 단계를 모두 수행할 필요는 없습니다.
- 1.5 저장을 클릭하고 VM을 재시작합니다.
2. 상태가 "Ready,SchedulingDisabled"인 노드를 찾습니다.
$ oc get node예:
3. 노드를 드레이닝하여 실행 중인 포드를 제거합니다.
$ oc adm <node name> --ignore-daemonsets --delete-emptydir-data --force예: oc adm drain c3-esx01.racka01.local --ignore-daemonsets --delete-emptydir-data --force
4. 디버그 모드를 설정하고 노드를 재부팅합니다.
$ oc debug node/<node name> $ sh-4.4# chroot /host $ sh-4.4# systemctl reboot
5. 재부팅 후 노드가 준비되면 예약 가능으로 표시합니다.
$ oc adm uncordon <node name>
6. 노드가 예약 가능으로 표시되었는지 확인합니다.
$ oc get node
해당 제품
APEX Cloud Platform for Red Hat OpenShift문서 속성
문서 번호: 000216593
문서 유형: Solution
마지막 수정 시간: 18 9월 2026
버전: 4
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.