OpenShift 가상화: OpenShift 가상화 UI에서 VM 스냅샷을 생성하지 못했습니다.

요약: OCP 클러스터의 VM에서 IO를 실행 중인 경우 OpenShift 가상화 UI를 통해 VM 스냅샷을 찍을 수 없습니다.

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

OpenShift 가상화 UI를 통해 VM 스냅샷을 생성하지 못했습니다.
image.png

virt-handler Pod(openshift-cnv 네임스페이스)의 로그를 확인하면 아래와 같은 오류가 표시됩니다.
2023-08-14T02:23:33.722372232Z {"component":"virt-handler","kind":"","level":"error","msg":"VMI를 고정하지 못했습니다.","name":"rhel9-vm-http-block",
"namespace":"rhel-vm","pos":"lifecycle.go:124","reason":"서버 오류.
명령 동결 실패: \"LibvirtError(Code=1, Domain=10, Message='내부 오류: QEMU 에이전트 명령 'guest-fsfreeze-freeze'를 실행할 수 없음:
/zoner/sda: 권한 거부됨')\"","timestamp":"2023-08-14T02:23:33.722321Z","uid":"c6894dc7-f29c-43e7-9817-3b12643040d1"}

원인

OpenShift 가상화를 통해 VM을 생성할 경우 생성된 LUN의 마운트 지점에 신뢰할 수 있는 레이블이 지정되지 않습니다. 따라서 VM 스냅샷 프로세스 중에 QEMU 에이전트는 마운트 지점(이 KB에서 마운트 지점은 /zoner/sda)을 열지 못하고 fsfreeze를 시도하는 동안 권한이 거부됩니다.

해결

아래 해결 단계에서는 "/zoner/sda"를 탑재 지점으로 가정합니다.

"df -h" 명령을 사용하고 오류 로그에서 확인하여 VM의 실제 오류 보고 탑재 지점을 확인하십시오.


1. 아래 명령을 실행하여 마운트 지점의 SELinux 컨텍스트에 "unlabeled_t"가 표시되는지 확인합니다.

# ls -lZd /zoner/sda/


2. "unlabeled_t"가 표시되면 두 가지 옵션으로 해결할 수 있습니다.

  • 옵션 1: QEMU 에이전트가 레이블이 지정되지 않은 파일을 읽을 수 있도록 합니다.
# setsebool -P virt_qemu_ga_read_nonsecurity_files 1

 

  • 옵션 2: 마운트 지점에 레이블을 지정합니다.
# restorecon -v /zoner/sda/

 

해당 제품

APEX Cloud Platform for Red Hat OpenShift
문서 속성
문서 번호: 000217270
문서 유형: Solution
마지막 수정 시간: 18 9월 2026
버전:  4
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.