PowerScale: SMB 프로세스의 audit_flt 드라이버가 CLOSED 상태이므로 노드를 사용할 수 없습니다
요약: OneFS 9.7 코드에서 SMB(Server Message Block) 프로세스에서 감사 드라이버가 제대로 로드되지 않는 문제가 발견되었습니다. 이로 인해 데이터 가용성 손실이 발생할 수 있습니다.
이 문서는 다음에 적용됩니다.
이 문서는 다음에 적용되지 않습니다.
이 문서는 특정 제품과 관련이 없습니다.
모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.
증상
이 문제는 9.7.1.0 - 9.7.1.7 릴리스 코드 수준을 실행하는 클러스터에 영향을 줄 수 있습니다.
주요 증상은 다음과 같습니다.
- SMB 사용자가 일부 또는 모든 노드에 액세스할 수 없습니다.
- 일부 또는 모든 노드의 SMB 서비스가
CLOSED상태. 에서 연결하는 동안CLOSED상태는 여러 가지 이유로 발생할 수 있으며 이 특정 문제와 관련된 증상이기도 합니다. 이를 확인하려면 다음 명령을 사용합니다.
isi_for_array -X 'netstat -an | grep "\.445 " | grep CLOSED | wc -l' | sort -V
모든 것을 볼 수 있습니다. '0' 출력에서. 다음은 이 문제가 발생하는 클러스터의 예입니다.
MyCluster-1# isi_for_array -X 'netstat -an | grep "\.445 " | grep CLOSED | wc -l' | sort -V
MyCluster-1: 208
MyCluster-2: 425
MyCluster-3: 2228
MyCluster-4: 146
MyCluster-5: 5284
MyCluster-6: 964
- 클러스터에서 감사가 활성화되어 있습니다. 다음 명령을 사용하여 확인합니다.
isi audit settings global view | grep "Protocol Auditing"
MyCluster-1# isi audit settings global view | grep "Protocol Auditing"
Protocol Auditing Enabled: Yes
- 클러스터가 영향을 받는 코드(9.7.1.0 - 9.7.1.7)를 실행하고 있습니다.
클러스터에 이 문제가 발생하는지 확인하려면 Dell 지원 부서에 서비스 요청을 제출하십시오. LWIO(Likewise Input/Output) 서비스에서 SMB 코어 덤프를 검사하는 데 도움이 될 수 있습니다.
원인
이 문제는 SMB 프로세스가 audit_flt 드라이버. 이 문제는 일반적으로 클러스터 간 코드 업그레이드 또는 페일오버 및 페일백 시와 같이 SMB 서비스가 재시작될 때 트리거됩니다. 그러나 어떤 이유로든 SMB가 재시작되는 경우 이 문제가 발생할 수 있습니다.
해결
이 문제를 완화하려면 SMB 서비스를 재시작하십시오. 정상적인 상황에서는 격리된 SMB 재시작으로 충분합니다.
MyCluster-1# killall -6 lwio
이 작업은 다음을 사용하여 여러 노드에서 수행할 수 있습니다. isi_for_array을 클릭합니다.
다음은 노드 1-4에서 SMB 서비스를 재시작하는 예입니다.
MyCluster-1# isi_for_array -n1-4 'killall -6 lwio'
이렇게 해도 문제가 완화되지 않으면 SMB 및 모든 종속성을 재시작해야 할 수 있습니다.
MyCluster-1# /usr/likewise/bin/lwsm restart lwio
다시 말하지만, 이 작업은 다음을 사용하여 여러 노드에서 동시에 수행할 수 있습니다. isi_for_array을 클릭합니다.
다음은 노드 1-4에서 SMB 스택을 재시작하는 예입니다.
MyCluster-1# isi_for_array -n1-4 '/usr/likewise/bin/lwsm restart lwio'
이 문제는 OneFS 9.7.1.8 코드 이상에서 해결되었습니다.
해당 제품
Isilon, PowerScale OneFS문서 속성
문서 번호: 000286634
문서 유형: Solution
마지막 수정 시간: 27 1월 2026
버전: 5
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.