Data Domain: Løsning af tilladelsesproblemer for storageenheder, der tilgås via CIFS

요약: Oprettelse af en CIFS-deling på en lagerenhed, der oprindeligt blev skrevet og administreret via Linux BoostFS, kan resultere i uoverensstemmelser i ejerskab og tilladelser. Dette kan medføre fejl i filadgang, "Adgang nægtet"-fejl, programfejl eller uventet funktionsmåde, når du får adgang til data via DD Boost. Problemet kan ofte løses ved at fjerne CIFS-sharet og gentildele ejerskabet af storageenheden til den relevante DD Boost-bruger. ...

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Et eller flere af følgende symptomer kan observeres:
Brugere modtager"You do not have permission to access this folder" eller"Access Denied" Meddelelser.
Programmer, der bruger DD Boost eller BoostFS kan ikke længere få adgang til tidligere tilgængelige filer eller mapper.
Filer eller mapper er synlige via én adgangsmetode, men ikke gennem en anden.
Sikkerhedskopiering, CyberSense eller andre DD Boost-baserede arbejdsprocesser rapporterer adgangs- eller tilladelsesrelaterede fejl.
BoostFS Tilsluttes korrekt, men specifikke mapper kan ikke åbnes eller optælles.

원인

En lagerenhed, der skrives og administreres via Linux BoostFS, er beregnet til at blive åbnet ved hjælp af DD Boost-ejerskabs- og tilladelseskontroller. Når en CIFS-deling senere oprettes mod den samme lagerenhed, kan Windows/CIFS-ejerskab og -adgangssemantik introduceres til data, der oprindeligt blev skrevet ved hjælp af Linux-baserede DD Boost-adgangsmetoder.
DD Boost og CIFS bruger forskellige mekanismer til administration af ejerskab, tilladelser og filadgang. Derfor er protokollerne ikke beregnet til at administrere det samme datasæt samtidigt. Introduktion af CIFS-adgang til en DD Boost-storageenhed kan føre til uoverensstemmelser i ejerskabet, der forhindrer DD Boost-programmer eller BoostFS-klienter i at få adgang til filer og mapper som forventet.

해결

Hvis den berørte storageenhed er blevet åbnet via et CIFS-share, og der er mistanke om problemer med DD Boost-adgangen, skal du fjerne CIFS-delingen og genoprette ejerskabet af storageenheden til den relevante DD Boost-bruger.

Mulighed 1: Fjern CIFS-sharet ved hjælp af Data Domain-brugergrænsefladen
Gå til protokoller > CIFS-shares > (placering kan variere efter DDOS-version).
Vælg det CIFS-share, der er knyttet til den berørte storageenhed.
Klik på Slet.
Når du bliver bedt om det, skal du bekræfte sletningen ved at klikke på OK.
Bekræft, at delingen ikke længere står på listen.

Mulighed 2: Fjern CIFS-delingen ved hjælp af CLI

Identificer det eksisterende sharenavn:

cifs share show

Slet delingen:

cifs share destroy <share-name>

Bekræft, at delingen er blevet fjernet:

cifs share show

Gentildel ejerskabet af storageenheden til den korrekte DD Boost-bruger:

ddboost storage-unit modify <storage-unit> user <correctUser>

Kontrollér, at BoostFS og eventuelle DD Boost-programmer kan få adgang til de berørte data.

 

Bemærk: For lagerenheder, der indeholder et stort antal filer, vises ikonet ddboost Kommandoen Storage-unit modify kan returnere timeout for filsystemkommunikation, mens ejerskiftet fortsætter i baggrunden. Denne funktionsmåde er dokumenteret i Dell KB Data Domain: DDBoost-ændring af storageenhed Kommandoen mislykkes med timeout for filsystemkommunikation og bør overvejes, når der udføres afhjælpning på store storageenheder. Kommandoen udfører opdateringer om ejerskab på tværs af alle filer i storageenheden og kan kræve yderligere tid at fuldføre.

Reference
Data Domain: DDBoost-storageenhedsændring Kommandoen mislykkes med timeout for filsystemkommunikation

해당 제품

Data Domain
문서 속성
문서 번호: 000486892
문서 유형: Solution
마지막 수정 시간: 09 7월 2026
버전:  1
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.