Data Domain: Řešení problémů s oprávněními u jednotek úložišť, ke kterým se přistupuje prostřednictvím systému CIFS.

요약: Vytvoření sdílené složky CIFS v úložné jednotce, která byla původně napsána a spravována prostřednictvím Linux BoostFS, může vést k nekonzistenci vlastnictví a oprávnění. To může vést k selhání přístupu k souborům, chybám "Přístup odepřen", selháním aplikace nebo neočekávanému chování při přístupu k datům prostřednictvím softwaru DD Boost. Problém lze často vyřešit odebráním sdílené složky CIFS a opětovným přiřazením vlastnictví úložné jednotky příslušnému uživateli softwaru DD Boost. ...

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Může být pozorován jeden nebo více z následujících příznaků:
Uživatelé obdrží"You do not have permission to access this folder" nebo"Access Denied" Zprávy.
Aplikace využívající funkci DD Boost nebo BoostFS Nelze již přistupovat k dříve přístupným souborům nebo adresářům.
Soubory nebo složky jsou viditelné jedním způsobem přístupu, ale ne jiným.
Zálohování, CyberSense nebo jiné pracovní postupy založené na softwaru DD Boost hlásí chyby související s přístupem nebo oprávněními.
BoostFS Připojení proběhlo úspěšně, ale určité adresáře nelze otevřít nebo vytvořit výčet.

원인

Jednotka úložiště, která je zapsána a spravována prostřednictvím Linux BoostFS, je určena pro přístup pomocí ovládacích prvků vlastnictví a oprávnění funkce DD Boost. Pokud je později sdílená složka CIFS vytvořena na stejné úložné jednotce, může být vlastnictví systému Windows/CIFS a sémantika přístupu zavedena do dat, která byla původně zapsána pomocí metod přístupu DD Boost založených na systému Linux.
DD Boost a CIFS používají různé mechanismy pro správu vlastnictví, oprávnění a přístupu k souborům. V důsledku toho nejsou protokoly určeny ke správě stejné datové sady současně. Zavedení přístupu CIFS k úložné jednotce DD Boost může vést k nekonzistenci vlastnictví, která zabrání aplikacím DD Boost nebo klientům BoostFS v přístupu k souborům a adresářům očekávaným způsobem.

해결

Pokud došlo k přístupu k dotčené úložné jednotce prostřednictvím sdílené složky CIFS a máte podezření na problémy s přístupem funkce DD Boost, odeberte sdílenou složku CIFS a obnovte vlastnictví úložné jednotky příslušného uživatele softwaru DD Boost.

Možnost 1: Odeberte sdílenou složku CIFS pomocí uživatelského rozhraní
Data Domain Přejděte do části Protocols > CIFS > Shares (umístění se může lišit podle verze systému DDOS).
Vyberte sdílenou složku CIFS přidruženou k dotčené úložné jednotce.
Klikněte na Odstranit.
Po zobrazení výzvy potvrďte odstranění kliknutím na tlačítko OK.
Ověřte, že sdílená složka již není uvedená.

Možnost 2: Odebrání sdílené složky CIFS pomocí rozhraní příkazového řádku

Identifikujte stávající název sdílené složky:

cifs share show

Odstraňte sdílenou složku:

cifs share destroy <share-name>

Potvrďte, že byla sdílená složka odebrána:

cifs share show

Přiřaďte vlastnictví úložné jednotky správnému uživateli softwaru DD Boost:

ddboost storage-unit modify <storage-unit> user <correctUser>

Ověřte, zda má BoostFS a všechny aplikace DD Boost přístup k dotčeným datům.

 

Poznámka: V případě úložných jednotek, které obsahují velký počet souborů, ddboost Příkaz k úpravě jednotky úložiště může vrátit časový limit komunikace systému souborů, zatímco změna vlastnictví pokračuje na pozadí. Toto chování je zdokumentováno v článku znalostní databáze Dell Data Domain: Příkaz k úpravě úložné jednotky DDBoost selže s vypršením časového limitu komunikace systému souborů a měl by být zvážen při provádění nápravy na velkých úložných jednotkách. Příkaz provádí aktualizace vlastnictví všech souborů v úložné jednotce a jeho dokončení může vyžadovat delší čas.

Reference
Data Domain: Příkaz k úpravě jednotky úložiště DDBoost selže s vypršením časového limitu komunikace systému souborů

해당 제품

Data Domain
문서 속성
문서 번호: 000486892
문서 유형: Solution
마지막 수정 시간: 09 7월 2026
버전:  1
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.