Data Domain: risoluzione dei problemi di autorizzazione per le unità di storage a cui si accede tramite CIFS

요약: La creazione di una share CIFS su un unità di storage originariamente scritta e gestita tramite Linux BoostFS può causare incoerenze di proprietà e autorizzazioni. Ciò può causare errori di accesso ai file, errori di "accesso negato", errori delle applicazioni o comportamenti imprevisti durante l'accesso ai dati tramite DD Boost. Il problema può spesso essere risolto rimuovendo la share CIFS e riassegnando la proprietà dell'unità di storage all'utente DD Boost appropriato. ...

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Possono essere osservati uno o più dei seguenti sintomi:
Gli utenti ricevono"You do not have permission to access this folder" o"Access Denied" Messaggi.
Applicazioni che utilizzano DD Boost o BoostFS Non è più in grado di accedere a file o directory precedentemente accessibili.
I file o le cartelle sono visibili tramite un metodo di accesso, ma non un altro.
Backup, CyberSense o altri flussi di lavoro basati su DD Boost segnalano errori di accesso o relativi alle autorizzazioni.
BoostFS Il mount ha esito positivo, ma non è possibile aprire o enumerare directory specifiche.

원인

È previsto l'accesso a un'unità di storage scritta e gestita tramite Linux BoostFS utilizzando i controlli di proprietà e autorizzazione di DD Boost. Quando in seguito viene creata una condivisione CIFS sulla stessa unità di storage, la proprietà di Windows/CIFS e la semantica di accesso possono essere introdotte nei dati originariamente scritti utilizzando metodi di accesso DD Boost basati su Linux.
DD Boost e CIFS utilizzano meccanismi diversi per la gestione della proprietà, delle autorizzazioni e dell'accesso ai file. Di conseguenza, i protocolli non sono progettati per gestire contemporaneamente lo stesso dataset. L'introduzione dell'accesso CIFS a un unità di storage DD Boost può causare incoerenze di proprietà che impediscono alle applicazioni DD Boost o ai client BoostFS di accedere a file e directory come previsto.

해결

Se si è effettuato l'accesso all'unità di storage interessata tramite una share CIFS e si sospettano problemi di accesso a DD Boost, rimuovere la share CIFS e restituire la proprietà dell'unità di storage all'utente DD Boost appropriato.

Opzione 1: rimuovere la condivisione CIFS utilizzando l'interfaccia utente
di Data Domain Passare a Protocols > CIFS > Shares (la posizione può variare in base alla versione di DDOS).
Selezionare la condivisione CIFS associata all'unità di storage interessata.
Cliccare su Delete.
Quando richiesto, confermare l'eliminazione cliccando su OK.
Verificare che la condivisione non sia più elencata.

Opzione 2: rimuovere la condivisione CIFS utilizzando la CLI

Identificare il nome della condivisione esistente:

cifs share show

Eliminare la share:

cifs share destroy <share-name>

Verificare che la condivisione sia stata rimossa:

cifs share show

Riassegnare la proprietà dell'unità di storage all'utente DD Boost corretto:

ddboost storage-unit modify <storage-unit> user <correctUser>

Verificare che BoostFS e tutte le applicazioni DD Boost possano accedere ai dati interessati.

 

Nota: Per le unità di storage contenenti un numero elevato di file, il ddboost Il comando di modifica dell'unità di storage può restituire un timeout di comunicazione del file system mentre la modifica della proprietà continua in background. Questo comportamento è documentato in Dell KB Data Domain: Il comando DDBoost storage-unit modify ha esito negativo con timeout di comunicazione del file system e deve essere preso in considerazione durante l'esecuzione della correzione su unità di storage di grandi dimensioni. Il comando aggiorna la proprietà su tutti i file nell'unità di storage e potrebbe richiedere più tempo per il completamento.

Data Domain di riferimento
: comando DDBoost di modifica dell'unità di storage con errore e timeout di comunicazione del file system

해당 제품

Data Domain
문서 속성
문서 번호: 000486892
문서 유형: Solution
마지막 수정 시간: 09 7월 2026
버전:  1
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.