NetWorker: Problemen met back-ups oplossen als gevolg van VSS-problemen

Samenvatting: Back-ups van een Windows-client mislukken als gevolg van VSS-problemen (Microsoft Volume Shadow Copy Service). Er zijn verschillende redenen die ertoe kunnen leiden dat VSS een snapshot op het clientbesturingssysteem niet kan verwerken; Bijvoorbeeld: Instabiele VSS-writer of onvoldoende ruimte om een snapshot te maken. VSS is vereist voor SYSTEM STATE of DISASTER RECOVERY: opslagsets of bij het voltooien van Block-Based Backups (BBB). VSS moet stabiel zijn en correct werken op het hostbesturingssysteem voordat het kan worden gebruikt met NetWorker-back-ups. ...

Dit artikel is van toepassing op Dit artikel is niet van toepassing op Dit artikel is niet gebonden aan een specifiek product. Niet alle productversies worden in dit artikel vermeld.

Symptomen

Back-ups van een Windows-client mislukken als gevolg van VSS-problemen. Er zijn verschillende redenen die ertoe kunnen leiden dat VSS een snapshot op het clientbesturingssysteem niet kan verwerken; Bijvoorbeeld: Instabiele VSS-writer of onvoldoende ruimte om een snapshot te maken.
OPMERKING: Dit KB-artikel beschrijft stappen voor Windows- of NetWorker-beheerders, maar aanhoudende VSS-problemen moeten voor verder onderzoek worden gemeld aan Microsoft Support.

Deze problemen worden meestal aangegeven in de back-uplogboeken die kunnen worden waargenomen in de NMC.
VSS OTHER: ERROR: VSS failed to process snapshot: 
90108:save: Unable to save the SYSTEM STATE save sets: cannot create the snapshot. 
7259:save: VSS reports adding volume [C:\] <file:///C:/]> to snapshot set failed for both hardware/software provider.VSS OTHER: ERROR: VSS failed to process snapshot: Unexpected VSS provider error.
VSS OTHER: ERROR: VSS failed to process snapshot: Insufficient storage available to create either the shadow copy storage file or other shadow copy data. (VSS error 0x8004231f)
90108:save: Unable to save the SYSTEM STATE save sets: cannot create the snapshot.
VSS-gerelateerde gebeurtenissen zijn ook zichtbaar in de Windows Event Viewer op de client.

Oorzaak

VSS is een functie van het Windows-besturingssysteem. VSS is vereist voor SYSTEEMSTATUS of NOODHERSTEL: opslagsets of bij het voltooien van Block-Based Backups (BBB). VSS moet stabiel zijn en correct werken op het hostbesturingssysteem voordat het kan worden gebruikt met NetWorker-back-ups.

Oplossing

Sluit eerst een potentieel capaciteitsprobleem uit. Microsoft raadt aan om 10-15% van de totale capaciteit van een schijf beschikbaar te houden voor het voltooien van VSS-snapshots. Als de capaciteit hoger is dan 90%, kunnen VSS-snapshots mislukken.

Om te testen of VSS al dan niet correct werkt op het clientbesturingssysteem, voert u de volgende opdrachten uit vanaf een beheerder-opdrachtprompt:
1. Controleer de status van de VSS-schrijvers: vssadmin list writers
Voorbeeld:

c:\>vssadmin list writers
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

Writer name: 'System Writer'
Writer Id: {e8132975-6f93-4464-a53e-1050253ae220}
Writer Instance Id: {34a07e16-fcdb-4ab0-b603-d58c0f741c9a}
State: [1] Stable
Last error: No error
...
...
OPMERKING: De bovenstaande output is een voorbeeld van een van de schrijvers; ALLE schrijvers moeten echter stabiel zijn, geen fout.


2. Als de schrijvers stabiel controleren op reeds bestaande snapshots, zou er geen moeten zijn: vssadmin list shadows
Voorbeeld:

c:\>vssadmin list shadows
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

No items found that satisfy the query.

3. Als er snapshots worden vermeld, verwijdert u deze: vssadmin delete shadows /all
Voorbeeld:
c:\>vssadmin delete shadows /all
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

Do you really want to delete 1 shadow copies (Y/N): [N]? y

Successfully deleted 1 shadow copies.
4. Zodra er geen snapshots zijn en het schijfstation minder dan 90% capaciteit gebruikt, probeert u een snapshot te maken: vssadmin create shadow /for=DRIVE_LETTER:\ 
Voorbeeld: 
c:\>vssadmin create shadow /for=C:\
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

Successfully created shadow copy for 'C:\'
    Shadow Copy ID: {1f6a1448-daad-4e68-a334-31dd40a64dd9}
    Shadow Copy Volume Name: \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy2
OPMERKING: U moet dit doen voor elk kritiek volume dat nodig is voor SYSTEM STATE of DISASTER_RECOVERY:\ save sets.


5. Als u met succes een snapshot hebt gemaakt, verwijdert u deze met de opdracht uit stap 3 en voert u een back-up uit van deze client. Als de back-up mislukt met een VSS-probleem, neemt u contact op met Dell NetWorker-support voor hulp. Het wordt ook aanbevolen om Microsoft-support in te schakelen voor het geval er samenwerking nodig is tussen NetWorker-support en Microsoft-support. 

Extra informatie

Vereisten VSS-ruimte: https://technet.microsoft.com/en-us/library/cc161409.aspxDeze hyperlink leidt u naar een website buiten Dell Technologies.
VSS-informatie: https://msdn.microsoft.com/en-us/library/windows/desktop/aa384625(v=vs.85).aspxDeze hyperlink leidt u naar een website buiten Dell Technologies.
Meer geavanceerde stappen voor het oplossen van VSS-problemen worden gedocumenteerd in: Opties voor VSS-tracering en probleemoplossing

Tijdelijke oplossing:

De volgende tijdelijke oplossing kan worden gebruikt om succesvolle back-ups te verkrijgen zonder VSS.

WAARSCHUWING: Dit is niet bedoeld als oplossing. Dit is bedoeld als tijdelijke tijdelijke oplossing die kan worden gebruikt totdat de VSS-problemen zijn opgelost. Zonder VSS kunt u geen DISASTER_RECOVERY:\ of SYSTEM_STATE back-ups maken. Alleen de data van het bestandssysteem worden beschermd. Deze tijdelijke oplossing is niet mogelijk bij het uitvoeren van Block-Based Backups (BBB).
  1. Meld u aan bij de NetWorker Management Console (NMC).
  2. Zorg ervoor dat de weergave-diagnostische>modus is ingeschakeld in de NMC.
  3. Open de eigenschappen van de Windows-client via het tabblad Protection-Clients>.
  4. Wijzig op het tabblad Algemeen van de clienteigenschappen het veld Sets opslaan zodat alleen volume-, map- of bestandsnamen worden opgenomen (bijvoorbeeld: C:\).
OPMERKING: Set opslaan Alles kan niet worden gebruikt. DISASTER_RECOVERY:\ kan niet worden opgegeven.
  1. Stel op het tabblad Apps en modules vss:*=off onder Bewerkingen opslaan.
  2. Maak een back-up van de client.
  3. Zodra de VSS-problemen zijn opgelost, verwijdert u de vss:*=off en stel het veld Opslagset van de client in op Alle, of voeg de DISASTER_RECOVERY:\ opslagset toe om de systeemstatus te verkrijgen.

Getroffen producten

NetWorker

Producten

NetWorker
Artikeleigenschappen
Artikelnummer: 000031318
Artikeltype: Solution
Laatst aangepast: 13 mrt. 2026
Versie:  6
Vind antwoorden op uw vragen via andere Dell gebruikers
Support Services
Controleer of uw apparaat wordt gedekt door Support Services.