AppSync: Onderhoudsabonnement mislukt of geeft een fout weer bij het bewerken vanwege "VPLEXClientFactory - kan vergrendeling niet verkrijgen binnen 5000/10000MILLISECONDEN"

Samenvatting: Een serviceplan met VPLEX kan mislukken met de fout "VPLEXClientFactory - could not obtain lock within 5000MILLISECONDS/10000MILLISECONDS." Tijdens het bewerken van het serviceplan en in de fase voor het maken en kopiëren van het VPLEX-cluster, wordt de fout ook weergegeven zoals hierboven. ...

Dit artikel is van toepassing op Dit artikel is niet van toepassing op Dit artikel is niet gebonden aan een specifiek product. Niet alle productversies worden in dit artikel vermeld.

Symptomen

Serviceplan mislukt of er worden fouten weergegeven tijdens het bewerken van de instellingen van het serviceplan. De fout is als volgt:

Voor klanten met AppSync 4.1.0.x is de fout:

concurrent access timeout on VPLEXClientFactory - could not obtain lock within 5000MILLISECONDS

Voor klanten met AppSync 4.2.0.x is de fout:

concurrent access timeout on VPLEXClientFactory - could not obtain lock within 10000MILLISECONDS

AppSync Server-logboeken geven de volgende fout weer:

<DATE & TIME> ERROR [default task-38] [org.jboss.as.ejb3.invocation] [AppSync Server] [] WFLYEJB0034: EJB Invocation failed on component VPLEXClientFactory for method public com.emc.archway.service.vplex.VPLEXClient com.emc.archway.service.vplex.VPLEXClientFactory.getClient(com.emc.archway.context.ExecutionContext,com.emc.archway.objectmodel.storage.vplex.VPLEXManagementServer) throws com.emc.archway.errorMessages.ArchwayException: javax.ejb.ConcurrentAccessTimeoutException: WFLYEJB0241: EJB 3.1 PFD2 4.8.5.5.1 concurrent access timeout on VPLEXClientFactory - could not obtain lock within 10000MILLISECONDS

 

Oorzaak

Het VPLEX-antwoord wordt niet ontvangen binnen de hard-gecodeerde time-out van AppSync.

Dit lijkt een probleem met de prestaties van VPLEX te zijn. Waarbij VPLEX op een bepaald moment traag reageert en AppSync de VPLEX-client niet kan ophalen binnen het hardgecodeerde time-outvenster van 5 s of 10 s. Vandaar dat dit de oorzaak is van de fout in het serviceplan.

De reden voor het krijgen van de foutmelding tijdens het bewerken van het serviceplan is ook dat AppSync VPLEX-informatie probeert te herontdekken voordat deze in de gebruikersinterface wordt weergegeven en er vanwege een prestatieprobleem van VPLEX een time-out optreedt.

Deze time-out bestaat in AppSync 4.1 en 4.2.

AppSync 4.1.0.x heeft een time-outwaarde van 5000 MILLISECONDEN (5 seconden).
AppSync 4.2.0.x heeft een time-outwaarde van 10000 MILLISECONDEN (10 seconden).

 

Oplossing

Upgrade naar AppSync 4.3 of hoger waar de time-outcontrole is geëlimineerd.

 

Producten

AppSync
Artikeleigenschappen
Artikelnummer: 000193937
Artikeltype: Solution
Laatst aangepast: 31 okt. 2025
Versie:  3
Vind antwoorden op uw vragen via andere Dell gebruikers
Support Services
Controleer of uw apparaat wordt gedekt door Support Services.