NVP-vProxy: Kan virtuele machine niet vergrendelen voor back-up: Another vProxy operation is active on VM

Samenvatting: De integratie van NetWorker VMware Protection (NVP) wordt geconfigureerd met de vProxy Appliance. De back-up van de virtuele machine (VM) voor sommige VM's mislukt met een consolidatiefoutbericht. ...

Dit artikel is van toepassing op Dit artikel is niet van toepassing op Dit artikel is niet gebonden aan een specifiek product. Niet alle productversies worden in dit artikel vermeld.

Symptomen

In het logboek van de vProxy-back-upsessie wordt het volgende weergegeven:

YYYY/MM/DD HH:MM:SS INFO: Found virtual machine "VM-NAME" with MORef "vm-###".
YYYY/MM/DD HH:MM:SS NOTICE: Virtual machine "VM-NAME" requires consolidation of its virtual disks.
YYYY/MM/DD HH:MM:SS ERROR: Failed to complete consolidation of virtual disks for "VM-NAME" (vm-###): Unable to access file since it is locked
YYYY/MM/DD HH:MM:SS WARN: Failed to consolidate virtual disks of virtual machine "VM-NAME" (vm-###): Failed to complete consolidation of virtual disks for "VM-NAME" (vm-###): Unable to access file since it is locked.
YYYY/MM/DD HH:MM:SS WARN: Failed to consolidate virtual disks of virtual machine "VM-NAME" (vm-###): Failed to complete consolidation of virtual disks for "VM-NAME" (vm-###): Unable to access file since it is locked.
YYYY/MM/DD HH:MM:SS NOTICE: Snapshot "snapshot-###" of virtual machine "VM-NAME" (vm-###) was removed.

De VM-sessielogboeken zijn te vinden op de vProxy onder: /opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE

U kunt ook de logboeken van de back-upsessie van de virtuele machine (VM) vinden op de NetWorker-server:

  • Linux: /nsr/logs/policy/POLICY_NAME/WORKFLOW_NAME
  • Windows (standaard): C:\Program Files\EMC NetWorker\nsr\logs\policy\POLICY_NAME\WORKFLOW_NAME\
OPMERKING: De NetWorker-beleidslogboeken volgen de retentie van de NetWorker-serverjobsdb (standaard 72 uur). Nadat de retentieperiode is verstreken, worden de logboeken verwijderd van de NetWorker-server, maar ze bestaan op de vProxy.

Oorzaak

Een eerdere back-up is onverwacht beëindigd en de snapshotschijven zijn nog steeds gekoppeld aan een vProxy-apparaat.

Oplossing

U kunt dit probleem oplossen door de Virtual Machine Disk (VMDK) van het vProxy-apparaat te verwijderen.

Optie één:

Gebruik ProxyHC Achtergebleven schijven verwijderen en verouderde sessies opschonen (indien gevonden).
Voor instructies over ProxyHCZie: NVP-vProxy: De healthcheck-tool ProxyHC gebruiken op een vProxy-apparaat
De vereiste ProxyHC-opties zijn: ProxyHC disk tasks cleanup

Optie twee:

Verwijder de VM-schijven uit de vProxy.

OPMERKING: Als er geen back-up- of herstelbewerkingen voor VM's worden uitgevoerd, mag de vProxy-VM slechts twee schijven bevatten. 
LET OP: Voer de onderstaande stappen alleen uit wanneer er geen back-up- of herstelacties worden uitgevoerd op de vProxy. U kunt dit bevestigen via de NetWorker Management Console (NMC), NetWorker Web User Interface (NWUI) of nsrwatch opdrachtregel op de NetWorker-server.
  1. Meld u aan bij de vSphere-webinterface.
  2. Klik met de rechtermuisknop op de back-up vProxy-appliance.
  3. Klik Instellingen bewerken.
  4. Vouw alle harde schijven uit.
  5. Selecteer de harde schijven die horen bij de virtuele machine met het probleem. Op de harde schijven van de VM moet de VM-naam in het pad van het schijfbestand worden weergegeven:
    vProxy VM-schijfinstellingen in vSphere 
  6. Klik op de X naast de harde schijf om de harde schijf los te koppelen van de VM.
    LET OP: Selecteer NIET Bestanden verwijderen uit de datastore.
  7. Klik op OK.
  8. Consolideer/verwijder de snapshot op de VM met behulp van de vSphere-webclient.

Extra informatie

Artikeleigenschappen
Artikelnummer: 000195596
Artikeltype: Solution
Laatst aangepast: 13 mei 2026
Versie:  4
Vind antwoorden op uw vragen via andere Dell gebruikers
Support Services
Controleer of uw apparaat wordt gedekt door Support Services.