Авамар: Збій збору сміття з MSG_ERR_TRYAGAINLATER

Resumo: Починаючи з версії 7.x, де резервне копіювання дозволено під час супроводу збирання сміття, іноді може з'являтися повідомлення «MSG_ERR_TRYAGAINLATER».

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

Завдання з обслуговування збору сміття Avamar завершується помилкою MSG_ERR_TRYAGAINLATER.

 

Щоб перевірити проблему:

  1. status.dpn Показує:

admin@avamarhost:~/>: status.dpn
...
Last GC: finished Mon Dec 23 06:08:00 2013 after 03m 05s >> recovered 0.00 KB (MSG_ERR_TRYAGAINLATER)

 

  1. Перевірте за допомогою кнопки dumpmaintlogs команда:

admin@avamarhost:~/>: dumpmaintlogs --types=gc --days=1
...
2013/12/23-12:08:00.9673 {0.0} <4202> failed garbage collection with error MSG_ERR_TRYAGAINLATER

 

  1. За бажанням, це можна перевірити в журналах сервера Avamar службою підтримки Avamar.

 

Causa

Це очікувана поведінка, яка відбувається, коли нові дані додаються до Avamar із резервних копій.

 

Коли контейнери для зберігання, або «смуги» на Avamar розділяються на дві частини, це називається «Index Stripe Splitting».

Це трапляється в рідкісних випадках рідко і лише після досягнення певних інтервалів потужності залежно від розміру вузла, кількості, версії тощо. Це завдання технічного обслуговування не може виконуватися під час ГХ.

 

Якщо індексна смуга розділяється при спробі виконання певних операцій GC, GC завершує роботу за допомогою MSG_ERR_TRYAGAINLATER.

Якщо індексна смуга запускає GC і вона повинна розділитися, вона чекає завершення операцій GC.

 

Індексні смуги на сітці, як правило, розділяються приблизно в один і той же період часу, що і один з одним на різних вузлах. Іноді це може зайняти кілька днів.

 

Resolução

Avamar працює за задумом.
Коли розбиття індексної смуги завершується, збір сміття відновлюється.

 

Щоб обійти цю проблему, не запускайте резервне копіювання під час GC.

 

Mais informações

  • Така поведінка не відбувається в мережі, яка знаходиться в «стаціонарному стані» (має стійке або зменшуване використання потужності), оскільки всі смуги, які повинні існувати, вже існують.
  • Така поведінка не відбувається в мережі, яка стала повноцінною і з тих пір зменшилася в ємності (не будучи розширеною новими вузлами). Це пов'язано з тим, що всі смуги, які можуть бути створені на сітці, вже існують.
  • Така поведінка може виникати після того, як вузол був доданий і існує додаткова ємність для подальшого розділення смуг.
  • Проблема може час від часу повторюватися і, швидше за все, її можна побачити в мережах Avamar, які переживають стійке зростання даних або які нещодавно були розширені додатковими вузлами.
  • Така поведінка може зберігатися протягом декількох днів.

 

Produtos afetados

Avamar

Produtos

Avamar
Propriedades do artigo
Número do artigo: 000163002
Tipo de artigo: Solution
Último modificado: 23 abr. 2025
Versão:  9
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.