Avamar: caminho de resolução para problemas de capacidade de metadados
Resumo: Este artigo do Caminho de resolução da capacidade de metadados pode ser usado como ponto de partida inicial para problemas de capacidade de metadados.
Sintomas
Sintomas de metadados:
Se o limite de capacidade de metadados tiver sido atingido ou excedido, o agendador de backup do Avamar poderá ser suspenso e impedir a execução de outros trabalhos de backup agendados.
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O painel de controle da interface do usuário do Avamar Administrator pode mostrar um valor de Capacidade de metadados igual ou superior a 100%.
- A saída de linha de comando do MCS (Management Console Server) mostra o valor de Capacidade de metadados igual ou superior a 100%:
Exemplo de comando e resultado:
mcserver.sh --status | grep -i metadataUtilization
metadataUtilization (larger of (nstripes/totalStripesPermitted) or (stripeReserved/(nodeSizeAfterDiskReadOnly * stripeUtilizationCapacityFactor)) * 100): 100.3
- Na interface do usuário do Avamar Administrator, o agendador e o dispatcher estão em estado "suspenso".
- No
mcserver logarquivos, uma mensagem é vista semelhante a "FINE: Suspendendo o despachante."
- Em uma consulta de status do MCS de linha de comando, o agendador é suspenso:
mcserver.sh --status | grep suspend
Backup dispatching: suspended
Introdução:
Em um ambiente Avamar com integração ao Data Domain, os backups podem ser armazenados no Data Domain.
Embora os dados de backup sejam enviados e armazenados no Data Domain, o Avamar mantém os registros dos metadados dos backups.
(Metadados, nesse tipo de ambiente, são as informações sobre os arquivos de backup, atributos de arquivo, diretórios e assim por diante do sistema operacional do client.)
Consulte a Nota técnica de monitoramento e geração de relatórios de capacidade de metadados para obter mais informações.
História:
- Como os bancos de dados tinham apenas alguns arquivos, havia apenas uma pequena quantidade de metadados para o Avamar rastrear.
- Os backups do file system no Data Domain não eram compatíveis com o Avamar v6.
- Isso era necessário devido aos backups do file system recém-compatíveis para o Data Domain.
- Com os backups do file system, muitos outros arquivos diferentes são submetidos a backup, cada um dos quais atributos e metadados devem ser rastreados pelo Avamar.
- Como os metadados têm um tamanho muito menor do que o conteúdo do arquivo de backup, eles podem se acumular e fazer com que outros tipos de limites de recursos sejam atingidos.
- A capacidade de metadados foi adicionada para proteger o servidor contra esse novo tipo de uso, excedendo as restrições e limites.
Causa
Geralmente, há uma das três situações em que a capacidade de metadados se torna alta ou é uma preocupação:
- Essa situação pode ser causada por backups intencionais ou acidentais no Avamar em vez do Data Domain
- Essa situação também pode ser causada por um Avamar anteriormente alto
GSANcapacidade ocorrida antes da integração do Data Domain.
- A alta capacidade de metadados é falsamente relatada, provavelmente devido a um erro de hardware ou a uma configuração incorreta.
- Esse processo garante que, se um upgrade continuar, ele não colocará a grade recém-atualizada em um estado de capacidade completa de metadados.
Resolução
1. Faça log-in no Avamar Utility Node como administrador.
2. Execute o seguinte comando para verificar a capacidade de metadados alta ou completa:
mcserver.sh --status | grep -i metadataUtilization
Exemplos:
metadataUtilization (larger of (nstripes/totalStripesPermitted) or (stripeReserved/(nodeSizeAfterDiskReadOnly * stripeUtilizationCapacityFactor)) * 100): 95.95
metadataUtilization (larger of (nstripes/totalStripesPermitted) or (stripeReserved/(nodeSizeAfterDiskReadOnly * stripeUtilizationCapacityFactor)) * 100): 100.3
Se a utilização não for alta, pare de usar este artigo.
3. Analise o artigo a seguir: Avamar: Como coletar as informações necessárias para solucionar problemas de capacidade.
4. Analise o artigo a seguir para verificar se não há nenhum outro tipo de problema de capacidade do Avamar presente: Avamar: solução de problemas, problemas e dúvidas sobre capacidade — Toda a capacidade (caminho de resolução)
5. Verifique se há um Data Domain conectado executando o seguinte comando:
ddrmaint read-ddr-info
Exemplos:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<avamar dpnid="1234567890" type="default" version="5">
<datadomain count="1">
<ddrconfig client-map-default="true" cloud_enabled="true" cloud_unit_name="ECS_Unit1" dd-cert-chain=" -----BEGIN CERTIFICATE----- ..... -----END CERTIFICATE-----" ddos-version="7.7.5.25-1078970" ddrcreatetime="1685672811" ddrid="ABCDEF0C18C7E2D75F20E0A1596E66AA2EE764E9" gsan-backup-target-default="true" hostname="dd.compamy.com" index="1" instant-access-limit="32" ipv4-hostname="dd.compamy.com" ipv6-hostname="" max-streams="50" max-streams-for-cp-backup="2" modelno="DD VE" mtree_name="/data/col1/avamar-1643691765" password="Onlh2XP9xEpvI2exqGQwqA==" policy_id="%2Fdata%2Fcol1%2Favamar-1234567890%3AECS_Unit1" serialno="AUDABCDEFGHIJK" token="AQBpud2RFZVF81Vv6NHMK/Y3jecFGhxv0KUif8BYoNk7iQ==" username="<ddboostuser">
<snmp community="noSejOLJ1lRsg1kEHjWdiA==" version="2">
<ports getter-setter="161" trap="163">
</ports>
</snmp>
<client-map>
</client-map>
<auth-type>credential</auth-type>
</ddrconfig>
</datadomain>
</avamar>
<4774>read-ddr-info: MSG_ERR_NOT_PRESENT: ddr_info does not exist.
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- Se não houver nenhum Data Domain conectado, é provável que esse seja um falso positivo causado por erros de hardware ou por uma configuração incorreta. Entre em contato com o suporte para obter assistência.
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- Se houver um Data Domain conectado e os limites de capacidade de metadados realmente tiverem sido atingidos ou forem muito altos, entre em contato com o suporte para obter assistência.
- Sempre que possível, inclua todas as informações coletadas e detalhes para ajudar a agilizar o tempo de resolução.
- Em alguns casos, o valor da capacidade de metadados pode ser reduzido ajustando parâmetros.
- Outras situações podem exigir novas limitações ou alterações de hardware. O membro da equipe de suporte do Avamar da Dell Technologies discutirá todas as ações necessárias.
- Sempre que possível, inclua todas as informações coletadas e detalhes para ajudar a agilizar o tempo de resolução.
- Se houver um Data Domain conectado e os limites de capacidade de metadados realmente tiverem sido atingidos ou forem muito altos, entre em contato com o suporte para obter assistência.
Mais informações
Para obter informações sobre como a capacidade de metadados é representada, consulte Avamar: O valor de utilização de metadados aumenta, mas nunca cai