SourceOne Email Management: O serviço Job Dispatcher interromperá os Job Business Components que são executados por mais de 30 minutos se nenhuma atualização de keep-alive for recebida

Resumo: O serviço Job Dispatcher interromperá os Job Business Components que são executados por mais de 30 minutos se nenhuma atualização de keep-alive for recebida. Erro: The dispatcher thread received an error from the Job Business Component ...

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas



Se um Job Business Component (JBC) encontrar um arquivo grande ou uma mensagem, isso poderá causar um tempo de espera excedido. Exemplo: Um trabalho de arquivamento de histórico apresenta falha ao processar uma caixa de correio com mensagens grandes de destinatários.  Quando uma mensagem grande está sendo processada, o JBC executa uma chamada de MAPI CopyTo ():

CExCompoundStgMsg::CreateMemoryMessage|VERBOSE|Total Recipients Count = <32265>; MaxRecips = <5000>; MaxWaitTime = <1500000>|ExCompoundStgMsg.cpp(1059)
CExCompoundStgMsg::CreateMemoryMessage|VERBOSE|Calling CopyTo in a separate thread - MaxRecips = <5000>; MaxWaitTime = <1500000>...|ExCompoundStgMsg.cpp(1063)


Enquanto o JBC está aguardando a conclusão do CopyTo (), ele é considerado como sem resposta pelo Job Dispatcher pois não está atualizando o pulso do keep-alive.  O Job Dispatcher registrará uma ou mais mensagens no ExJobDispatcher.exe.log indicando que o trabalho não está ativo e será interrompido:

CExDispatchThread::MonitorActiveJobs|INFO|Stopping job Id: <Job ID> which is not alive|ExDispatchThread.cpp(1484)

Depois que o trabalho for encerrado, o Job Dispatcher registrará:

CExJobThread::Run|ERROR-LOGD|The dispatcher thread received an error from the the Job Business Component (JBC): <JBC Name>, HR: 0x86043243. (0x86040906)|ExJobThread.cpp(1375)

Causa

O tempo de consulta do keep-alive usado pelo serviço do Job Dispatcher é de 30 minutos por padrão.  Todos os JBCs que não puderem responder dentro desse tempo poderão ser encerrados, pois serão considerados como sem resposta. 

Resolução

Esse problema é resolvido em patches ou versões de pacote de serviços do SourceOne Email Management versão 7.2.9 ou posterior. Hot Fix 1

Os kits de pacote de serviços e pacotes de hotfix estão disponíveis para download pelo link https://www.dell.com/support.
* Os hotfixes estão disponíveis apenas para as versões mais recentes de patch ou pacote de serviços do produto que estavam disponíveis quando esse problema foi resolvido.
** Note que é sempre recomendável fazer upgrade para a versão mais recente do SourceOne, do pacote de serviços e do pacote de Hot Fix para garantir que todos os problemas atualmente resolvidos sejam corrigidos, inclusive o problema mencionado acima

Uma atualização do tempo de espera excedido deve ser implementada no banco de dados SQL. Entre em contato com o suporte para obter ajuda para fazer essa alteração. Consulte esta KB n.º 542289. 

Produtos afetados

SourceOne

Produtos

SourceOne, SourceOne Email Management
Propriedades do artigo
Número do artigo: 000173285
Tipo de artigo: Solution
Último modificado: 05 mai. 2026
Versão:  4
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