Dell EMC Unity: Sob certas condições de espaço insuficiente do sistema de arquivos, o upgrade para o código 5.1 pode falhar (pode ser corrigido pelo usuário)

Resumo: Em determinadas condições de falta de espaço, o upgrade para a versão 5.1 pode acionar problemas de cache e reinicializações simultâneas da SP.

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

Após o upgrade para a versão 5.1, as SPs não serão totalmente iniciadas ou talvez fiquem sendo reinicializadas continuamente.  Elas podem indicar problemas com a perda de cache.

Causa

Esse problema é causado por um sistema de arquivos que está sem espaço para inodes e não consegue criar o "OrphanDir", um novo recurso da versão 5.1.  A criação do OrphanDir usa 13 inodes. Se um sistema de arquivos não tiver 13 inodes disponíveis, a criação falhará e o sistema de arquivos não será instalado, causando uma pane na SP.

Resolução

Correção:
Uma correção está sendo criada.  Consulte este artigo da base de conhecimento para obter mais informações.

Solução temporária:
Antes do upgrade, verifique se o sistema Unity tem os inodes adequados disponíveis.  Consulte o campo Informações adicionais abaixo para ver os comandos que devem ser usados para verificar o espaço disponível para inodes, antes da atualização.

Se um sistema de arquivos estiver com esse problema, basta estender o sistema de arquivos para corrigir o problema e adicionar espaço suficiente para permitir o upgrade. 
  • Estender o sistema de arquivos em pelo menos 10 GB deve ser o suficiente.  
  • Depois que o sistema de arquivos for estendido, crie um arquivo no sistema de arquivos.  Isso garantirá que a fração de inodes seja adicionada ao sistema de arquivos.
Depois de implementar a solução temporária, verifique o espaço novamente e certifique-se de que haja espaço suficiente para inodes (pelo menos, 13 inodes livres) antes de prosseguir com o upgrade.

Mais informações

Para verificar a existência desse problema:

1. Execute o seguinte comando em uma sessão shell do Unity:

svc_storagecheck -s | grep -A1 inodes

19:21:42 service@Unity spa:~/user# svc_storagecheck -s | grep -A1 inodes
1630610514: ADMIN: 6:  Filesystem      inodes         used         avail   capacity Mounted on
1630610514: ADMIN: 6:   536870913     2331376           93       2331283         0% /
--
1630610514: ADMIN: 6:  Filesystem      inodes         used         avail   capacity Mounted on
1630610514: ADMIN: 6:   536870916     1291504           16       1291488         0% /test1
--
1630610514: ADMIN: 6:  Filesystem     inodes          used         avail   capacity Mounted on
1630610514: ADMIN: 6:   536870920     771568            19        771549         0% /testfs2
--
1630610514: ADMIN: 6:  Filesystem     inodes          used         avail   capacity Mounted on
1630610514: ADMIN: 6:   536870922     771568            82        771486         0% /.etc


Se o sistema Unity estiver com o problema, um sistema de arquivos parecido com este será exibido:

1630610514: ADMIN: 6:  Filesystem      inodes         used         avail   capacity Mounted on
1630610514: ADMIN: 6:   536870916     1291504      1291504             0       100% /test1


Observe que não há inodes disponíveis, e o sistema de arquivos está com 100% de capacidade de inodes.

Produtos afetados

Dell EMC Unity
Propriedades do artigo
Número do artigo: 000191205
Tipo de artigo: Solution
Último modificado: 11 mai. 2026
Versão:  9
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.