Dell Automation: NativeEdge Virtual Machine memory oversubscription
Resumo: This article describes a deployment scenario that has been observed to cause memory oversubscription on a NativeEdge Virtual Machine (VM). Memory oversubscription may result in loss of access to the affected VMs. ...
Este artigo aplica-se a
Este artigo não se aplica a
Este artigo não está vinculado a nenhum produto específico.
Nem todas as versões do produto estão identificadas neste artigo.
Sintomas
During a multi-VM deployment on a single endpoint of NativeEdge an oversubscription of resources may occur.
In the example below, a PowerEdge R760 with 128 GB of memory was used to deploy three VMs whose combined memory allocation totalled 144 GB.
Within the Automation Platform UI, all three VMs are reported as Running.

Automation Platform Alerts will contain warnings for VM memory resources being exceeded.

Attempting to open a VM console to one of the affected VMs results in the message:
‘failed to connect to server’

Causa
When deploying NativeEdge VMs in Dell Automation Platform, the system validates the resources consumed by an endpoint, including, but not limited to, memory usage. This validation is intentionally designed to allow multiple VMs to be deployed, provided that resource constraints are respected at the moment each VM is powered on.
Resolução
To recover from this condition, uninstall any VMs or deployments that cause the ECE endpoint to exceed its available resource capacity. A future version of Automation Platform will include enhanced verification to prevent these rare VM oversubscription scenarios from occurring.
Please refer to Dell NativeEdge: Guidelines for System Memory and CPU Reservations on a NativeEdge Endpoint for endpoint overhead considerations.
Produtos afetados
Dell Automation Platform, NativeEdge Solutions, Dell Automation Platform Components, NativeEdgePropriedades do artigo
Número do artigo: 000435738
Tipo de artigo: Solution
Último modificado: 16 mar. 2026
Versão: 1
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.