Polecenie SRA "discoverDevices" — błąd "Nie udało się połączyć z hostem zarządzania macierzą" w lokacji głównej

Сводка: Polecenie "discoverDevices" modułu replikacji pamięci masowej (SRA) kończy się niepowodzeniem z komunikatem "Nie udało się połączyć z hostem zarządzania macierzą" w lokacji głównej.

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

Błąd w dziennikach SrdfSRA z dowolnej lokalizacji:

[03/23 16:12:54  08332                      0114  SymapiSession::Init                      ] Initializing SYMAPI session for remote server [1xx.1x.2.1:2707]
[03/23 16:12:54  08332                      0120  SymapiSession::Init                      ] SymInit() [ReadModifyNowrite]
[03/23 16:12:58  08332                      0130  SymapiSession::Init                      ] [ERROR]: Failed to perform SymInit().
 
[ERROR]: [SYMAPI_C_NET_OPR_ERROR : A remote send or receive operation failed]
[03/23 16:12:58  08332                      0025  SymapiSession::SymapiSession             ] [ERROR]: Failed to initialize Symapi session

Błąd w dzienniku storsrvd narzędzia Solutions Enabler:

03/23/2022 16:12:55.835  : ANR0151E Common Name in client certificate not valid: expected "SrmHostname", received "storsrvd fac838c410cd"

Or

03/23/2022 16:12:55.835  : ANR0151E Common Name in client certificate not valid: expected "SrmHostname", received "storsrvd 1xx.1x.2.1"

Причина

Przyczyny tego problemu mogą być następujące:
  • Zablokowana zapora — każdy host platformy Docker Site Recovery Manager (SRM) lub SRA musi mieć możliwość nawiązania połączenia z demonem storsrvd obu hostów Solutions Enabler (SE). Domyślny port to 2707.
  • Nazwa hosta lub adres IP systemu nazw domen (DNS) nie są poprawnie rozpoznawane.
  • Nieprawidłowy certyfikat klienta
  • Wszystkie urządzenia RDF (Remote Data Facility) są w trybie kopiowania adaptacyjnego. SRA ignoruje wszystkie urządzenia RDF w kopii adaptacyjnej.

Разрешение

Zespół zapory użytkownika musi otworzyć port 2707 (lub inny port, jeśli użytkownik zmienił domyślny port storsrvd).

Istnieją trzy opcje rozwiązywania problemu z certyfikatem klienta:
  • Ustaw storsrvd na serwerze tak, aby nie weryfikował (ignorował) zmiennych certyfikatu klienta w wierszu poleceń:
  1. Otwórz installdir/symapi/config/daemon_options i ustaw zmienną, jak pokazano poniżej, a następnie uruchom ponownie demona storsrvd:
storsrvd:SECURITY_CLT_SECURE_LVL  = NOVERIFY
  • Ustaw storsrvd na serwerze tak, aby używał niezabezpieczonych połączeń:
  1. Otwórz installDir/symapi/config/options i ustaw zmienną, jak pokazano poniżej, a następnie uruchom ponownie demona storsrvd:
SYMAPI_SECURITY_LEVEL = NONSECURE
  • Zaktualizuj certyfikat Solutions Enabler w oknie dokowanym SRA:
  1. Zaloguj się do dokera SRM jako "admin".
  2. Przełącz na użytkownika root
su root
  1. Nawiązywanie połączenia z oknem dokowanym
Zrzut ekranu przedstawiający nawiązywanie połączenia z programem Docker
  1. Sprawdź bieżącą nazwę hosta certyfikatu SE
Sprawdź bieżącą nazwę hosta
  1. Jeśli certyfikat nie zawiera nazwy hosta, utwórz nowy certyfikat
Tworzenie nowego certyfikatu
  1. Hasło skrytki to "dockerID@SELockbox1". W tym przykładzie jest to "0c6837ce4e7b@SELockbox1".

Дополнительная информация

Sprawdzanie rozwiązywania problemów:
  • Sprawdź konfigurację macierzy.
  • Spróbuj użyć adresu IP i nazwy hosta, aby wykluczyć problemy z DNS.
  • Sprawdź, czy demon RDF jest uruchomiony po obu stronach i włączony w pliku opcji.
  • Sprawdź, czy dane uwierzytelniające użytkownika vCenter są obecne
symcfg auth list -vmware
  • Sprawdź, czy środowisko ma otwartą sieć.
  • Sprawdź, czy port 2707 nasłuchuje, wyklucz problemy z zaporą.
  • Upewnij się, że nie ma problemów z łączem RDF.
Свойства статьи
Номер статьи: 000167652
Тип статьи: Solution
Последнее изменение: 14 Feb 2024
Версия:  3
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.