Birincil Sitede "discoverDevices" SRA Komutu "Dizi yönetimi ana bilgisayarına bağlanılamadı" hatası

Сводка: Depolama Çoğaltma Adaptörü (SRA) "discoverDevices" komutu, birincil sitede "Dizi yönetimi ana bilgisayarına bağlanılamadı" iletisiyle başarısız oluyor.

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

Her iki siteden de SrdfSRA günlüklerinde hata:

[03/23 16:12:54  08332                      0114  SymapiSession::Init                      ] Initializing SYMAPI session for remote server [1xx.1x.2.1:2707]
[03/23 16:12:54  08332                      0120  SymapiSession::Init                      ] SymInit() [ReadModifyNowrite]
[03/23 16:12:58  08332                      0130  SymapiSession::Init                      ] [ERROR]: Failed to perform SymInit().
 
[ERROR]: [SYMAPI_C_NET_OPR_ERROR : A remote send or receive operation failed]
[03/23 16:12:58  08332                      0025  SymapiSession::SymapiSession             ] [ERROR]: Failed to initialize Symapi session

Solutions Enabler storsrvd günlüğünde hata:

03/23/2022 16:12:55.835  : ANR0151E Common Name in client certificate not valid: expected "SrmHostname", received "storsrvd fac838c410cd"

Or

03/23/2022 16:12:55.835  : ANR0151E Common Name in client certificate not valid: expected "SrmHostname", received "storsrvd 1xx.1x.2.1"

Причина

Bu sorunun nedenleri şunlar olabilir:
  • Engellenmiş bir güvenlik duvarı: Her bir Site Recovery Manager (SRM) veya SRA docker ana bilgisayarı, Solutions Enabler (SE) ana bilgisayarlarının her iki storsrvd daemon'una da bağlanabilmelidir. Varsayılan bağlantı noktası 2707'dir.
  • Etki Alanı Adı Sistemi (DNS) ana bilgisayar adı veya IP'si doğru şekilde çözümlenmedi.
  • Yanlış istemci sertifikası
  • Tüm Remote Data Facility (RDF) aygıtları uyarlamalı kopyalama modundadır. SRA, uyarlamalı kopyadaki tüm RDF aygıtlarını yok sayar.

Разрешение

Kullanıcının güvenlik duvarı ekibi, 2707 numaralı bağlantı noktasını (veya kullanıcı varsayılan storsrvd bağlantı noktasını değiştirmişse başka bir bağlantı noktasını) açmalıdır.

İstemci sertifikasını çözümlemek için üç seçenek vardır:
  • Sunucudaki storsrvd değerini, komut satırı isteminde istemci sertifikası değişkenlerini doğrulamayacak (yoksaymayacak) şekilde ayarlayın:
  1. installdir/symapi/config/daemon_options dosyasını açıp değişkeni aşağıda gösterildiği gibi ayarlayıp storsrvd daemon'u yeniden başlatın:
storsrvd:SECURITY_CLT_SECURE_LVL  = NOVERIFY
  • Sunucudaki storsrvd'yi Güvenli olmayan bağlantıları kullanacak şekilde ayarlayın:
  1. installDir/symapi/config/options değişkenini açıp aşağıda gösterildiği gibi ayarlayın ve storsrvd daemon'u yeniden başlatın:
SYMAPI_SECURITY_LEVEL = NONSECURE
  • SRA docker'da Solutions Enabler sertifikasını güncelleştirin:
  1. SRM docker'da "admin" olarak oturum açın.
  2. Kök kullanıcıya geç
su root
  1. Docker a bağlanma
Docker a bağlanma ekran görüntüsü
  1. SE sertifikasının geçerli ana bilgisayar adını kontrol edin
Geçerli ana bilgisayar adını kontrol edin
  1. Sertifikada ana bilgisayar adı listelenmiyorsa yeni bir sertifika oluşturun
Yeni sertifika oluşturma
  1. Kasa parolası: "dockerID@SELockbox1". Bu örnekte, '0c6837ce4e7b@SELockbox1'.

Дополнительная информация

Sorun Giderme Kontrolleri:
  • Dizi yapılandırmasını kontrol edin.
  • DNS sorunlarını ortadan kaldırmak için IP ve ana bilgisayar adını kullanmayı deneyin.
  • RDF daemon'ın her iki tarafta da çalışır durumda olduğunu ve seçenekler dosyasında etkin olduğunu doğrulayın.
  • vCenter kullanıcı kimlik bilgilerinin mevcut olduğunu doğrulayın
symcfg auth list -vmware
  • Ortamın açık bir ağa sahip olduğunu doğrulayın.
  • 2707 numaralı bağlantı noktasının sizi dinlediğinden emin olun, güvenlik duvarı sorunlarını eleyin.
  • RDF bağlantı sorunu olmadığından emin olun.
Свойства статьи
Номер статьи: 000167652
Тип статьи: Solution
Последнее изменение: 14 Feb 2024
Версия:  3
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.