NetWorker:カスタム提供の0バイト Writerlist.txt ファイルの後にエラー「Windowsの役割と機能のライター リストを取得できませんでした」が表示される

Сводка: カスタム提供の0バイト長のwriterlist.txt ファイルでは、VSS(ボリューム スナップショット サービス)バックアップの準備でライターの検証手順が失敗します。

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

クラスター内の1つのノードでVSSバックアップ エラーが発生しています。他のノードは常に成功しますが、問題のあるリソースは失敗し、次のエラー メッセージが表示されます。
11/16/17 17:42:37.343548 WINDOWS ROLES AND FEATURES: sow_init_save_sysset_walker () called 11/16/17 17:42:37.343548 WINDOWS ROLES AND FEATURES: sow_save: Failed to get writers list for WINDOWS ROLES AND FEATURES: WINDOWS ROLES AND FEATURES: ERROR: Failed to get writers list for WINDOWS ROLES AND FEATURES: 95088:save: Cannot back up the volume save set because the initialization of VSS did not succeed.
これは、VSSライターが正しく認識されず、VSS操作が完了しない状況を示しています。

このエラーは、スケジュール設定されたバックアップ ポリシーと save コマンドを使用できます。

Причина

実行 save エラーを再現するには、両方のノード ホストでコマンドを実行する必要があり、生成されたログを並べて比較できます。
C:\Program Files\EMC NetWorker\nsr\bin>save -D9 -s myserver -b Datadomain -o "VSS:NSR_SYS_WRITER_WIN32_SERVCOMP_USER=yes" C:\Lgto\nmsap91_win_x64\win_x64\networkr\file_to_backup
次のメソッドがトリガーされるまで、2つのログは同期しています。
PopulateSupportedWriterList() Enter
この後、両方のノードに次の情報が表示されます。
CVssSysReqBackup::Init(): Successfully updated writer list.
次に、両方のノードが次のメソッドを使用してライター検証ステップを開始します。
IsWriterSupported()
ここから違いが始まります。
  • ノード1:
IsWriterSupported() Enter.
04/10/18 11:22:57.671021 VSS Writer {d61d61c8-d73a-4eee-8cdd-f6f9786b7xxx} is supported
04/10/18 11:22:57.671021 IsWriterSupported() Exit
[for each writer]
  • ノード2:
IsWriterSupported() Enter.
04/10/18 11:14:17.601823 VSS Writer {d61d61c8-d73a-4eee-8cdd-f6f9786b7xxx} is not supported
04/10/18 11:14:17.601823 IsWriterSupported() Exit
[for each writer]
最後に、以下がノード2で受信されます。
95088:save: Cannot back up the volume save set because the initialization of VSS did not succeed
NODE ONEでは、デバッグログは、メソッドの実行中に、 デフォルトでサポートされているシステムライターリストが使用されていることを示しています。
 PopulateSupportedWriterList() 
04/10/18 11:22:56.702238 PopulateSupportedWriterList() Enter./n04/10/18 11:22:56.702238 lgwstat: Failed to open file/directory: \\?\C:\Program Files\EMC NetWorker\nsr\bin\writerlist.txt
04/10/18 11:22:56.702238 PopulateDefaultSupportedWriterList() Enter.
04/10/18 11:22:56.702238 PopulateDefaultSupportedWriterList() Exit
しかし、NODE TWOでは、以下が完了して使用されているようです。
PopulateUserSupportedWriterList() 
代わりに、
PopulateDefaultSupportedWriterList().
04/10/18 11:14:16.664317 PopulateSupportedWriterList() Enter.
04/10/18 11:14:16.664317 PopulateUserSupportedWriterList() Enter.
04/10/18 11:14:16.664317 PopulateUserSupportedWriterList() Exit
クライアント ファイル システムのノード2でチェックすると、 0バイト ファイルであるユーザー提供のライター リストがあることがわかります。
C:\Program Files\EMC NetWorker\nsr\bin>dir writerlist.txt
Volume in drive C has no label.
Volume Serial Number is 5F41-F8xx
Directory of C:\Program Files\EMC NetWorker\nsr\bin
11/10/2017  10:01 AM                 0 writerlist.txt
1 File(s)              0 bytes
0 Dir(s)  33,237,905,408 bytes free
これは、メソッドの実行中にライターリストを設定するために使用されます。
 PopulateUserSupportedWriterList()
何も含まない 0 バイトのファイルであるため、
PopulateUserSupportedWriterList() 
サポート対象外として設定されたライターに対して、整合性のあるデータ構造を作成できません。

Разрешение

ノード2ファイル システムから0バイト ファイルを削除する必要があります。
C:\Program Files\EMC NetWorker\nsr\bin\writerlist.txt
使用する場合:
PopulateDefaultSupportedWriterList()
の完了を許可します save 操作.

削除が完了したら、次の手順を実行します。
  • ノード2:
PopulateSupportedWriterList() Enter./n04/11/18 14:31:10.389231 lgwstat: Failed to open file/directory: \\?\C:\Program Files\EMC NetWorker\nsr\bin\writerlist.txt04/11/18 14:31:10.389231 PopulateDefaultSupportedWriterList() Enter.
04/11/18 14:31:10.389231 PopulateDefaultSupportedWriterList() Exit.
04/11/18 14:31:10.389231 PopulateSupportedWriterList() Exit.

NODE ONEと同様です。VSSバックアップは、ノード2で可能になりました。

Затронутые продукты

NetWorker Family, NetWorker, NetWorker Series
Свойства статьи
Номер статьи: 000056703
Тип статьи: Solution
Последнее изменение: 29 Jul 2025
Версия:  4
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.