Поиск и устранение аппаратных неполадок ленточной библиотеки в NetWorker
Сводка: Данная статья предназначена для помощи службам поддержки и администраторам NetWorker в проверке проблем на уровне библиотеки или транспорта, чтобы исключить проблемы на уровне хоста и приложения. ...
Симптомы
- Невозможно надежно использовать библиотеку для резервного копирования NetWorker
- Получение ошибок или сообщений ASC/ASCQ/SCSI SENSE в системных журналах или журналах приложений
- Не удается обнаружить наличие библиотеки на предполагаемом хосте управления роботом
- Невозможность перехода библиотеки в состояние готовности в NetWorker
- Спорадические или последовательные ошибки при выполнении определенных или случайных операций с библиотекой
Причина
Если библиотека работала ранее и внезапно столкнулась с проблемой, подумайте о возможных изменениях, которые могут препятствовать работе:
- Изменение микропрограммы, драйвера или конфигурации робота, коммутатора или адаптера
- Добавление, замена или удаление ленточного оборудования, ленточных картриджей или других библиотечных компонентов
- Изменение версии программного обеспечения NetWorker, исправлений операционной системы
- Любое событие оборудования, такое как отключение питания или перезагрузка любого компонента в пути передачи данных.
- Любые действия, связанные с открытием двери библиотеки
Разрешение
Чтобы выявить проблему оборудования в ленточной библиотеке, необходимо проверить операции на самых разных уровнях. Чтобы изолировать проблему, транспорт на основе SCSI удаляется из пути передачи данных для тестирования чисто библиотечных функций.
Имейте в виду, что некоторые компоненты библиотеки могут оказаться функциональными. Сбой скрытого компонента может по-прежнему препятствовать правильной работе библиотеки для приложений хоста. Например, робот может правильно перемещать объемы, но его внутренняя логика может неправильно идентифицировать серийные номера дисков или потерять из виду расположение элементов. Команда может быть успешно выполнена через веб-интерфейс, но библиотеке может не удастся войти в коммутатор SAN. Это может указывать на проблему с модулем GBIC или распределительной платой на стороне целевого устройства.
Выполните следующие базовые тесты, чтобы убедиться, какие функции работают на каждом интерфейсе. Воспользуйтесь этими методами для попытки восстановления, прежде чем обращаться к поставщику библиотеки.
Библиотечное оборудование — ЖК-панель
Начните поиск и устранение неисправностей как можно локальнее робота - для большинства администраторов библиотеки это означает панель дисплея на передней панели библиотечного блока. Начиная с этого этапа, можно исключить проблемы, связанные с транспортом SCSI, Ethernet или графическим веб-интерфейсом пользователя.
- Проверка на наличие ошибок - как правило, очевидная неисправность в хранилище отображается в виде кода ошибки либо в главном окне, либо в подменю 'Оповещения' или 'Ошибки'. Обо всех обнаруженных здесь проблемах следует немедленно сообщать поставщику (невыполнение этого требования может усугубить ущерб).
- Протестируйте основные операции в пользовательском интерфейсе (те же, что проверяются на ЖК-дисплее).
- Перемещайте ленточную кассету от разъема к накопителю, от накопителя к накопителю, от накопителя к разъему и от разъема к разъему.
- Если существует слот импорта и экспорта или магазин, протестируйте те же функции с ними, используя все комбинации исходного и целевого ресурсов, как описано выше.
- Протестируйте физический экспорт и импорт ленточных картриджей из библиотеки и в библиотеку.
- Протестируйте функции инициализации, инвентаризации и сброса библиотеки, если они доступны.
- Если ленточный картридж не удается извлечь из роботизированной руки, накопителя или разъема, необходимо вручную извлечь его из библиотеки, прежде чем продолжить.
- Подтвердите представление данных:
- Убедитесь в правильности расположения, штрихкодов и состояния ленточных картриджей.
- Проверьте, какие функции библиотеки, если таковые имеются, включены, и подтвердите эффекты.
- Виртуальные библиотеки не имеют ЖК-дисплеев, но их работоспособность можно проверить на самом примитивном уровне в командной строке устройства хранения, которое их виртуализирует; Как и в случае с физическими библиотеками, может потребоваться помощь поставщика с его специализированными инструментами и знаниями.
- Сведения о тестировании библиотеки Data Domain см. в разделе Устранение неполадок с видимостью целевых объектов виртуальной ленточной библиотеки
- Сведения о тестировании дисковой библиотеки Dell см. в разделе Поиск и устранение неисправностей сервера EDL или поиска и устранения неисправностей связи между приложением резервного копирования (BSP) и EDL.
Library Intelligence — пользовательский веб-интерфейс
Следующим общедоступным уровнем тестирования является веб-интерфейс, который служит пользовательским интерфейсом библиотеки. Этот интерфейс является общим как для физических ленточных библиотек, так и для виртуальных ленточных библиотек и предназначен для обеспечения комплексного доступа к библиотеке и ее функциям.
Этот метод тестирования позволяет обойти обычный путь передачи данных SCSI, включая адаптер главной шины (HBA), коммутаторы и целевые порты. Он отправляет команды SCSI непосредственно со встроенного веб-сервера роботу. Таким образом, он может не быть истинным представлением реальных проблем, возникающих при стандартном использовании.
- Как указано выше, проверьте пользовательский интерфейс на наличие оповещений, очередей ошибок или индикаторов в интерфейсе. Опять же, о проблемах, о которых сообщает библиотека, следует немедленно сообщать поставщику.
- По возможности проверьте основные операции в пользовательском интерфейсе, как это делалось на ЖК-дисплее
- Подтвердите данные в пользовательском интерфейсе, как это было сделано на ЖК-дисплее, включая подключение к хосту, расположение штрихкодов, серийные номера дисков и любые другие соответствующие данные
Библиотечное обслуживание — Поставщик:
Если в библиотеке нет неисправностей, но возникли аппаратные проблемы на уровне коммутатора, транспорта или хоста, обратитесь к поставщику. Они могут устранять неполадки с помощью специализированных инструментов и знаний. Перед выполнением следующих действий:
- Полностью выключите питание библиотеки и оставьте без питания (а в идеале — без розетки) на 5 минут. Большим устройствам, таким как ленточные библиотеки, требуется время, чтобы конденсаторы разрядились и потенциально устранили условия неисправности.
- Организуйте обновление прошивки для робота и дисков (часто для этого в любом случае требуется помощь производителя). Для аппаратных проблем лучше всего использовать текущий код.
- Убедитесь, что все неисправные кабели или диски удалены из библиотеки. Нередки случаи, когда один неисправный компонент влияет на другие компоненты. По возможности замените все подозрительные компоненты для проверки, чтобы еще больше локализовать проблему.
Дополнительная информация
Networker: Поиск и устранение неисправностей ленточной библиотеки в NetWorker
Служба поддержки может предоставить рекомендации, используя указанные выше критерии, но мы не располагаем ресурсами по ОС, HBA или поставщикам робототехнических средств. Это ограничение может привести к длительному и неудачному поиску и устранению неисправностей.