PowerFlex. Не удалось восстановить PFMP из резервной копии, если пароль не закодирован в кодировке Base64

Сводка: Во время восстановления PowerFlex Manager Platform (PFMP) процесс прерывается, так как сценарий ожидает пароли CIFS и шифрования в кодировке base64. Предоставление простых паролей приводит к сбою. ...

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

При восстановлении PowerFlex Manager из резервной копии пароли должны быть в формате base64

 

Пример ошибки, когда пароль шифрования неверен или неправильно закодирован 


  

Пример ошибки, когда пароль шифрования не закодирован

 

Пример ошибки, когда пароль CIFS неверен или неправильно закодирован 

Пример ошибки, когда пароль CIFS не закодирован

Причина

Пользователь ввел простой пароль, а не зашифрованный пароль, выполнив следующие действия

Please enter CIFS password(base64 encoded). Press enter to skip if username is not required: 

Please enter encryption password for backup file (base64 encoded): 

Разрешение

Выполните следующую команду, чтобы закодировать пароль в формат base64. 

echo -n 'MyPassword' | base64

Замените Mypassword , в котором пароль будет закодирован

Обязательно выполните следующие действия.

  • Введите пароль между 2 одинарными кавычками ' '
  • Используйте аргумент -n в команде echo, чтобы избежать символа новой строки в конце 

Пример:

 Пример кодировки пароля   

В этом примере пароль был закодирован в cGFzc3dvcmQ=

 

Перезапустите сценарий восстановления и убедитесь, что при запросе используется новый закодированный пароль, а не простой пароль 

Please enter CIFS password(base64 encoded). Press enter to skip if username is not required: cGFzc3dvcmQ=

Please enter encryption password for backup file (base64 encoded): cGFzc3dvcmQ=

Дополнительная информация

Полные инструкции по восстановлению PowerFlex Manager можно найти в руководстве пользователя Dell PowerFlex Manager 4.8.x . Копия также указана ниже. 

 

 

  • Восстановление PowerFlex Manager

При восстановлении PowerFlex Manager пользовательские данные возвращаются в более раннюю конфигурацию, которая сохраняется в файле резервной копии. Для восстановления из резервной копии необходимо запустить сценарий вне PowerFlex Manager. Пользовательский интерфейс не поддерживает возможность восстановления из резервной копии.

Предварительные условия

Перед началом процедуры восстановления необходимо выполнить следующие необходимые условия:

  • Кластер восстановления должен быть точно такой же, как версия PowerFlex и версия Kubernetes.
  • Кластер восстановления должен иметь точно такие же IP-адреса и такую же конфигурацию.

    Конфигурация кластера должна совпадать с конфигурацией кластера, в котором была создана резервная копия.

    • Все узлы Kubernetes должны иметь одинаковые IP-адреса.
    • Все узлы Kubernetes должны иметь одинаковые имена.
    • Все IP-адреса балансировщика нагрузки должны быть одинаковыми.
Об этой задаче
Внимание! При восстановлении более ранней конфигурации PowerFlex Manager перезапускается и удаляются данные, созданные после файла резервной копии, в который выполняется восстановление. Кроме того, можно завершить любые запущенные задания.
Действия
  1. Войдите на узел, где был первоначально запущен установщик платформы PowerFlex Manager.
  2. Запустите сценарий восстановления, включенный в пакет установщика:
./restore_backup.sh
  1. При необходимости укажите сведения для выполнения сценария.
    Вам будет предложено ввести имя пользователя и пароль SSH. Кроме того, вам будет предложено указать, одинаковы ли пароли для всех узлов, а также указать расположение файла резервной копии и зашифрованный пароль для файла. Вам также может потребоваться ввести имя пользователя и пароль CIFS. Учетные данные CIFS могут не потребоваться для сетевой папки CIFS, которая допускает анонимный доступ.
     
    Примечание. Пароли должны быть в формате base64.

    Чтобы закодировать пароль в base64, используйте следующую команду 

    echo -n 'MyPassword' | base64

    Замените Mypassword, который пароль будет закодирован, убедитесь, что пароль введен между 2 одинарными qoutes ' ' '

    Пример:

    echo -n 'example' | base64
    ZXhhbXBsZQ==
    

    Чтобы завершить выполнение сценария восстановления, необходимо указать, будет ли операция восстановления выполняться в существующем или новом кластере.

    Ниже приведен фрагмент кода, в котором показан пример выполнения сценария восстановления:

    [root@sheetal-installer scripts]# ./restore_backup.sh
    
    /usr/local/lib/python3.8/site-packages/paramiko/transport.py:236: CryptographyDeprecationWarning: Blowfish has been deprecated "class": algorithms.Blowfish, Installation logs are available at <Bundle root>/PFMP_Installer/logs/ directory. More detailed logs are available at <Bundle root>/atlantic/logs/ directory. PFMP Installer is about to reset a PFMP cluster based on the configuration specified in the PFMP_Config.json.
    
    Please enter the ssh username for the nodes specified in the PFMP_Config.json[root]:root
    
    Are passwords the same for all the cluster nodes[Y]?:Y
    
    Please enter the ssh password for the nodes specified in the PFMP_Config.json. Password:
    
    Please enter backup file location - Example CIFS: \\1.2.3.4\Lab\backup\file.tgz
    
    Please enter CIFS username. Press enter to skip if username is not required:administrator
    
    Please enter CIFS password(base64 encoded). Press enter to skip if username is not required: UmFpZDR1cyE=
    
    Please enter encryption password for backup file (base64 encoded): UmFpZDR1cyE=
    
    Perform restore on existing cluster? Please enter yes/y or no/n :
    
        
Результаты

В процессе восстановления информация о состоянии выводится до завершения восстановления.

Затронутые продукты

PowerFlex rack, ScaleIO
Свойства статьи
Номер статьи: 000464562
Тип статьи: Solution
Последнее изменение: 18 May 2026
Версия:  3
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.