NVP vProxy: Il backup delle VM ha esito negativo con errore "snapshot has already been deleted or has not been completely created"

Сводка: Il backup delle VM ha esito negativo con errore "snapshot has already been deleted or has not been completely created"

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

  • I backup delle VM eseguiti con l'appliance NVP vProxy segnalano il seguente errore:
YYYY-MM-DDTHH:mm:SSZ ERROR: Request to remove snapshot 'snapshot-#####' on VM 'VM_NAME' was rejected by vCenter 'VCENTER_NAME': ServerFaultCode: The object 'vim.vm.Snapshot:snapshot-#####' has already been deleted or has not been completely created

Причина

Nel datastore erano presenti file di istantanee precedenti per questa VM.

Разрешение

L'utilità ProxyHC può essere utilizzata per pulire i dischi e le istantanee. 

Per eseguire la pulizia manuale in VMware, effettuare le seguenti operazioni:
  1. Accedere al web client vSphere.
  2. Cliccare con il pulsante destro del mouse sulla VM e selezionare Snapshots-Delete> All Snapshots.
  3. Cliccare con il pulsante destro del mouse sulla VM e selezionare Snapshots-Consolidate>.
  4. Selezionare la scheda Datastores e individuare la directory della VM, verificare la presenza di eventuali file di istantanee. Se qui risiedono dei file di istantanee, eliminarli.
  5. Se non vengono rilevate istantanee, ma il problema persiste, tentare di creare una snapshot da VMware.
NOTA:Se la VM esegue backup coerenti con le applicazioni (MSVMAPPAGENT), eseguire una snapshot inattiva; in caso contrario, eseguire una snapshot non inattiva.
  1. Ripetere i passaggi da 2 a 4 per assicurarsi che i file delle istantanee vengano rimossi.
  2. Eseguire un backup.

All'inizio dei backup delle VM, vProxy richiede a vCenter di creare una snapshot per la VM, una richiesta viene inviata alla fine del backup per rimuovere la snapshot. Il vCenter Server crea, gestisce ed elimina i file di snapshot. Se il problema persiste o si verifica un errore durante uno dei passaggi precedenti, contattare il supporto VMware per assistenza.

Затронутые продукты

NetWorker

Продукты

NetWorker
Свойства статьи
Номер статьи: 000172495
Тип статьи: Solution
Последнее изменение: 28 May 2025
Версия:  4
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.