Avamar -Linuxクライアント バックアップのサイズは、「/var/log/lastlog」とスパース ファイル処理の動作が原因で誤解を招く可能性があります。

Сводка: Avamar Linuxクライアント バックアップのサイズは、「/var/log/lastlog」とスパース ファイル処理の動作が原因で誤解を招く可能性があります。

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

この記事で説明されている動作は、Avamarバックアップ サイズのレポート作成に影響する可能性があります。
これは、Avamarバックアップで保護されているデータの量について報告する必要がある場合に重要です。たとえば、サービス プロバイダーがクライアントの金額についてエンド ユーザーに請求する場合などです。

/var/log/lastlog が含まれているLinuxクライアント バックアップの報告されたサイズは、クライアントが使用可能なディスク領域の合計よりも大きい場合があります。

例:
Linuxクライアントは、39 MBのデータを含む/var/logディレクトリのみをバックアップするように構成されています。
root@linuxclient:~/#: du -hs /var/log
39M /var/log

/var/logディレクトリとバックアップに「lastlog」が含まれています。  
root@linuxclient:/var/log/#: ls -ltrhs /var/log/lastlog
48K -rw-rw-r-- 1 root root 272G Apr 30 11:46 /var/log/lastlog

メモ: lastlogはディスク上で48 Kの領域を消費しますが、通常の報告サイズは272 GBです。これはスパース ファイルです。バックアップが完了すると、avtarは272 GBのデータをバックアップしたと主張しています。
 
2015-04-30 12:08:09 avtar Info <5163>: Backup complete, wrapping-up session with Server
2015-04-30 12:08:10 avtar Info <5156>: Backup #494 timestamp
2015-04-30 12:21:58, 131 files, 16 directories, 272.0 GB (5 files, 6.830 KB, 0.00% new)
2015-04-30 12:08:10 avtar Info <7539>: Label "MOD-1430395268242", scheduled to expire after 06/29/15 (2015-06-29 12:01:07 UTC), none backup
2015-04-30 12:08:10 avtar Info <6083>: Backed-up 272.0 GB in 20.83 minutes: 783 GB/hour (377 files/hour)


バックアップされるデータ量に対して報告される値が 、Linuxファイル システムのサイズよりも大きい。
root@linuxclient:~/#: df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda2 7.9G 2.4G 5.1G 32% /
/dev/sda1 122M 13M 103M 12% /boot
none 3.0G 0 3.0G 0%
/dev/shm /dev/sda3 1.5G 125M 1.3G 9% /var


Причина

ユーザー(人間またはその他)がシステムにログインするたびに、ファイル/var/log/lastlogが変更されます。Avtarは、 Avamar およびスパース ファイルで説明されているスパース ファイル処理の制限により、ファイル全体を処理する必要があります

Разрешение

対処方法1: /var/log/lastlogをバックアップから除外します。

監査目的で lastlog をバックアップする必要がある場合は、lastlogの出力を出力ファイル
に送信するようにスケジュール設定された日次crontabを作成することを検討してください。たとえば、
lastlog > /var/log/lastlog_$(date +%d%m%Y).log

通常のファイルlastlog_<日付はバックアップされますが、元のスパース lastlog ではバックアップされません。


>回避策2: ユーザーIDの範囲を減らし、「lastlog」を縮小します。

このような高いユーザーIDが必要かどうかを検討します。指定された範囲内のすべてのユーザーIDを消費する可能性がありますか?
下位のユーザーIDが同等に機能している場合は、次の操作が役立つ可能性があります。 
  • /etc/passwd を編集して、ユーザーIDの範囲ができるだけ小さいことを確認します。
  • lastlog ファイルの名前を変更し、 touch lastlog を使用して再作成します。所有権と権限を元のファイルと同じに設定します。
  • ユーザーとシステムに接続して、新しく作成された lastlog ファイルを更新します。
root@linuxclient:/var/log/#: ls -ltrhs | grep lastlog
36K -rw-r----- 1 root tty 272G Apr 28 09:44 lastlog.old
8.0K -rw-r----- 1 root tty 143K Apr 28 09:50 lastlog

Дополнительная информация

注1:
パフォーマンスの観点から見ると、大規模なスパース ファイルのバックアップにはかなりの時間がかかります。「lastlog」の性質上、ファイルは変更される可能性が高く、毎日完全に処理する必要があります。スパース ファイルの詳細
については、「Avamarおよびスパース ファイル 」を参照してください。

 注2:
ファイル /var/log/lastlog は、サイズが/etc/passwdファイルに存在するuserIDの範囲に依存するスパース ファイルです。

前述の例では、/etc/passwdには当初、502という高いユーザーIDがありました。  

ファイルはスパースでしたが、中程度です。報告されたファイル サイズが小さかった。
root@linuxclient:/var/log/#: ls -ltrhs /var/log/lastlog
16K -rw-rw-r-- 1 root root 143K Apr 30 11:26 /var/log/lastlog


userIDが大きいユーザーを追加すると、lastlogのサイズがレポートされたサイズを大幅に増加します。次の図に示すように、userIDが高いほど、lastlogのスパース(および報告されたサイズ)が大きくなります。

高いユーザーIDを持つユーザーを追加します。
root@linuxclient:/var/log/#: useradd sparsetest -u 999999 

ユーザー スパーステストが作成されました。
root@linuxclient:/var/log/#: tail -1 /etc/passwd sparsetest:x:999999:999999::/home/sparsetest:/bin/bash

lastlogファイルのサイズが増加します。
root@linuxclient:/var/log/#: ls -ltrhs /var/log/lastlog
32K -rw-rw-r-- 1 root root 279M Apr 30 11:34 /var/log/lastlog

さらに高いuserIDを持つユーザーを追加します。
root@linuxclient:/var/log/#: useradd sparsetest2 -u 999999999

lastlogファイルはさらにスパースになります。
root@linuxclient:/var/log/#: ls -ltrhs /var/log/lastlog
48K -rw-rw-r-- 1 root root 272G Apr 30 11:46 /var/log/lastlog 

Затронутые продукты

Avamar

Продукты

Avamar
Свойства статьи
Номер статьи: 000164572
Тип статьи: Solution
Последнее изменение: 10 Feb 2025
Версия:  5
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.