SRM 4.8. Запланированные отчеты типа «Интерактивная таблица» отправляются только с данными из первого дочернего отчета

Сводка: Запланированные отчеты типа «Интерактивная таблица» отправляются только с данными из первого дочернего отчета. Существует временное решение, позволяющее гарантировать отправку полных данных из предполагаемого родительского отчета. ...

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

При планировании отчета типа «Интерактивная таблица» SRM может отправить отчет с данными для первого дочернего отчета вместо разыскиваемого родительского отчета.
Пример:
- Разыскиваемый отчет может быть следующим: Все >> Библиотека отчетов: необходимо отправить тома инвентаризации>>Dell PowerStore>>, то есть отчет обо всех томах PowerStore.>>
- Эта проблема также наблюдается в отчете Dell Powerscale Quotas в SRM 4.10 и SRM 5.0
. Экспорт вручную со страницы отчета позволяет получить желаемый и ожидаемый результат.
- Однако, если отчет запланирован для будущих запусков, экспорт отчета будет содержать подробные данные только для одного тома (т. е. первого тома в списке).

Причина

В коде SRM имеется ошибка при выборе идентификатора отчета при планировании любого отчета типа «Интерактивная таблица». Вместо идентификатора нужного родительского отчета выбирается и сохраняется идентификатор первого дочернего отчета. Когда расписание запускает отчет позже, оно создает выходные данные для неправильно выбранного и сохраненного идентификатора дочернего отчета.

Разрешение

Инженерный отдел SRM оценивает требования для решения этой проблемы в предстоящем выпуске продукта. Временное решение доступно, как описано в этой статье.
 
ВНИМАНИЕ! Временное решение проблемы заключается в временном изменении определения отчета. Будьте внимательны при редактировании отчетов по умолчанию и внимательно следуйте инструкциям. Если у вас есть сомнения, откройте сервисную заявку и укажите номер этой статьи базы знаний.

Решение:
1) Удалите все ранее запланированные отчеты, которые подвержены этой проблеме — их невозможно исправить, и их необходимо запланировать повторно.
2) Откройте затронутый отчет в пользовательском интерфейсе SRM.
3. Войдите в режим редактирования этого отчета и откройте вкладку «Конфигурация отчета».
4. Убедитесь, что в поле Тип отчета отображается «интерактивная таблица». Не продолжайте, если в типе указано что-либо другое.
5) В раскрывающемся списке измените тип отчета на «стандартная таблица». Не вносите никаких других изменений в определение отчета.
6. Нажмите «Сохранить » в нижней части экрана и вернитесь в режим обзора.
7) Запланируйте отчет с желаемыми параметрами (Расписание, Хранение, Электронная почта, Удаленная передача и т. д.). 
8) Снова войдите в режим редактирования и установите для параметра «Тип отчета» значение «интерактивная таблица».
9. Нажмите «Сохранить » и вернитесь в режим обзора.

После применения временного решения отчет будет работать в обычном режиме в пользовательском интерфейсе, как и раньше. Запланированный отчет будет отправлен вместе с данными, как и ожидалось. Можно вносить изменения в расписание отчета, электронную почту и параметры формата, не влияя на правильное функционирование запланированного отчета.
Свойства статьи
Номер статьи: 000206019
Тип статьи: Solution
Последнее изменение: 21 May 2024
Версия:  3
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.