Résumé de l'article : l’installation du système d’exploitation sur une machine virtuelle hébergée sur un système Dell PowerEdge peut échouer lorsque l’hyperviseur n’est pas préparé pour la prise en charge de l’installation. Cet article explique comment préparer l’hyperviseur pour l’utilisation d’un support ROK.
Symptômes
Au cours de l’installation du système d’exploitation sur la machine virtuelle, le message suivant s’affiche et l’installation échoue :
System verification Failure
[English]
This hypervisor is not prepared for the Reseller Option Kit(ROK) media install or you are trying to install the ROK media on a non-Dell system.
To prepare the hypervisor for the ROK install, please follow the steps mentioned in the ROK document at https://www.dell.com/ostechsheets and then try again
Press OK to restart the virtual machine
Ce message d’erreur s’affiche également en français, en allemand et en espagnol. Si vous cliquez sur redémarrer, le même message d’erreur s’affiche.
Cause
Vous pouvez installer le support ROK uniquement sur les systèmes Dell PowerEdge et les machines virtuelles (VM) hébergées sur les systèmes Dell. Si vous tentez d’installer le système d’exploitation (SE) du serveur Windows sur un système PowerEdge non Dell ou sur une machine virtuelle hébergée sur un système Dell PowerEdge, l’installation peut échouer et le message d’échec de vérification du système s’affiche. Lorsque le programme d’installation tente d’accéder au BIOS de la machine afin de s’assurer que l’installation s’effectue sur un serveur Dell, l’hyperviseur fournit un BIOS qui ne correspond pas, ce qui génère le message d’erreur.
Solution
La solution consiste à permettre au programme d’installation d’accéder au BIOS physique du serveur. Veuillez suivre les procédures en fonction de l’hyperviseur que vous utilisez pour préparer l’installation.
- Hyperviseur Windows HyperV
- VMWare ESXi
- Serveur Citrix Xen
Hyperviseur Windows HyperV
Pour préparer votre
hyperviseur Microsoft pour l’utilisation du support Rok :
- Insérez le support ROK, puis accédez à <Lecteur DVD>: \ROK.
- Exécutez hyperv_prep.vbe sur le système d’exploitation Windows Server qui exécute Hyper-V, et suivez les instructions qui s’affichent à l’écran.
Remarque : si vous exécutez l’utilitaire sur Microsoft Hyper-V Server 2008, Hyper-V Server 2008 R2 ou 2016, saisissez
cscript hyperv_prep.vbe dans la CLI.
VMWare ESXi
Pour préparer votre
hyperviseur ESX/ESXi pour l’utilisation du support Rok :
- Accédez à /vmfs/volumes/<nom du datastore>/<nom de la MV>.
- Ouvrez le fichier <Nom de la MV>.vmx dans un éditeur et ajoutez la ligne suivante : smbios.reflectHost = TRUE
Remarque : assurez-vous de modifier le fichier VMX pour toutes les machines virtuelles que vous créez.
Instructions détaillées
1) Mettez la machine virtuelle hors tension et, à partir de vSphere Client, accédez au datastore où la machine virtuelle est stockée.
2) Cliquez avec le bouton droit de la souris sur le datastore et sélectionnez Browse DataStore.
3) Accédez au dossier dans lequel la machine virtuelle est stockée, dans ce cas, « Orion ».
4) Dans le dossier, cliquez avec le bouton droit de la souris sur le fichier « Orion.vmx » et sélectionnez Télécharger.
5) Utilisez un éditeur de texte pour modifier le fichier. Voici le contenu d’origine du fichier :
6) Ajoutez ce qui suit dans la dernière ligne.
Smbios.reflecthost = "TRUE".
7) Enregistrez les modifications et téléchargez le fichier dans le datastore.
8) Cliquez sur « Yes » dans Upload/Download Operating Warning.
9) Mettez la machine virtuelle sous tension et poursuivez l’installation du système d’exploitation.
Serveur Citrix Xen
Pour préparer votre hyperviseur Citrix XenServer à l’utilisation du support ROK, assurez-vous que la version de XenServer est la version 5.5 ou supérieure.
Suivez la procédure adaptée à votre hyperviseur pour réussir l’installation de la machine virtuelle.