PowerStore : Le plug-in VSI ne met pas à jour ou ne lit pas les pratiques d’excellence de l’hôte
Summary: Impossible d’appliquer les pratiques d’excellence de l’hôte via le plug-in VSI dans vCenter
Bu makale şunlar için geçerlidir:
Bu makale şunlar için geçerli değildir:
Bu makale, belirli bir ürüne bağlı değildir.
Bu makalede tüm ürün sürümleri tanımlanmamıştır.
Symptoms
Après l’enregistrement de vCenter dans le plug-in VSI, VSI ne parvient pas à appliquer les pratiques d’excellence de l’hôte. Cependant, aucune erreur n’est signalée dans vCenter.
Cause
Dans ce cas, le mot de passe vCenter contenait le caractère « barre verticale » (« | »), qui provoquait l’échec de l’appel API, comme indiqué dans la sortie du journal VSI ci-dessous :
Dans l’erreur ci-dessus, XXX_XXx faisait partie du mot de passe vCenter de XXX|XXX_XXx. L’appel API de VSI interprétait le mot de passe comme une commande en raison du caractère « barre verticale » (« | »). Cela entraînait l’échec de l’application des pratiques d’excellence de l’hôte.
2021-03-01 01:33:20 [pool] ERROR c.e.i.c.c.ExecuteResult:23 - /bin/sh: XXX_XXx: command not found Exception ignored in: <_io.TextIOWrapper name='<stdout>' mode='w' encoding='ANSI_X3.4-1968'> BrokenPipeError: [Errno 32] Broken pipe
Dans l’erreur ci-dessus, XXX_XXx faisait partie du mot de passe vCenter de XXX|XXX_XXx. L’appel API de VSI interprétait le mot de passe comme une commande en raison du caractère « barre verticale » (« | »). Cela entraînait l’échec de l’application des pratiques d’excellence de l’hôte.
Resolution
Remplacez le caractère spécial incorrect par un caractère spécial pris en charge. Dans ce cas, le caractère « barre verticale » (« | ») a été remplacé par le caractère « @ ». Il est recommandé d’utiliser des caractères spéciaux qui ne peuvent pas être interprétés comme une commande, et donc d’éviter les caractères tels que le caractère « barre verticale » « | » et le point d’exclamation « ! ».
Les étapes suivantes doivent être suivies :
1) Réinitialiser le mot de passe vCenter
2) Annuler l’enregistrement de vCenter dans VSI
3) Réenregistrer vCenter dans VSI
4) Appliquer les pratiques d’excellence de l’hôte
Les étapes suivantes doivent être suivies :
1) Réinitialiser le mot de passe vCenter
2) Annuler l’enregistrement de vCenter dans VSI
3) Réenregistrer vCenter dans VSI
4) Appliquer les pratiques d’excellence de l’hôte
Additional Information
Remarque supplémentaire à prendre en compte. Lors du réenregistrement de vCenter dans VSI, une adresse IP incorrecte peut être associée au FQDN de vCenter en raison de la présence d’un adaptateur HA configuré pour l’hôte vCenter. Dans ce cas, l’adaptateur HA a été ajouté après l’enregistrement VSI d’origine. Lorsque la tentative de réenregistrement a été effectuée, une erreur « Incorrect Password » est survenue. Après investigation, il a été constaté que VSI associait l’adaptateur HA en tant qu’adaptateur réseau principal pour l’hôte vCenter, ce qui provoquait l’erreur de mot de passe. L’adaptateur HA a été supprimé de l’hôte et le réenregistrement a réussi.
Etkilenen Ürünler
PowerStoreMakale Özellikleri
Article Number: 000184245
Article Type: Solution
Son Değiştirme: 22 Ağu 2024
Version: 3
Sorularınıza diğer Dell kullanıcılarından yanıtlar bulun
Destek Hizmetleri
Aygıtınızın Destek Hizmetleri kapsamında olup olmadığını kontrol edin.