PowerStore: Il plug-in VSI non aggiorna o non legge le best practice per l'host
Summary: Impossibile applicare le best practice per l'host tramite il plug-in VSI in vCenter
Bu makale şunlar için geçerlidir:
Bu makale şunlar için geçerli değildir:
Bu makale, belirli bir ürüne bağlı değildir.
Bu makalede tüm ürün sürümleri tanımlanmamıştır.
Symptoms
Dopo aver registrato vCenter nel plug-in VSI, VSI non riesce ad applicare le best practice per l'host; tuttavia, non è stato segnalato alcun errore in vCenter.
Cause
In questo caso, la password di vCenter conteneva il carattere pipe "|", che causava l'errore della chiamata API, come illustrato nell'output del registro VSI riportato di seguito:
Nell'errore riportato sopra, XXX_XXx faceva parte della password di vCenter XXX|XXX_XXx. La chiamata all'API VSI interpretava la password come comando a causa del carattere pipe "|". Di conseguenza, non è stato possibile applicare la best practice dell'host.
2021-03-01 01:33:20 [pool] ERROR c.e.e.i.c.c.ExecuteResult:23 - /bin/sh: XXX_XXx: command not found Exception ignored in: <_io. TextIOWrapper name='<stdout>' mode='w' encoding='ANSI_X3.4-1968'> Broken PipeError: [Errno 32] Tubo rotto
Nell'errore riportato sopra, XXX_XXx faceva parte della password di vCenter XXX|XXX_XXx. La chiamata all'API VSI interpretava la password come comando a causa del carattere pipe "|". Di conseguenza, non è stato possibile applicare la best practice dell'host.
Resolution
Sostituire il carattere speciale errato con un carattere speciale supportato. In questo caso, il carattere barra verticale "|" è stato sostituito con il carattere "@". Si consiglia di utilizzare caratteri speciali che non possono essere interpretati come un comando, ad esempio il carattere barra verticale "|" e il carattere
di barra verticale "!" Sarà necessario seguire i seguenti passaggi: 1) Reimpostare la password di vCenter 2) Annullare la registrazione di
vCenter in VSI 3) Ripetere la registrazione di
vCenter in VSI
4) Applicare la best practice dell'host
di barra verticale "!" Sarà necessario seguire i seguenti passaggi: 1) Reimpostare la password di vCenter 2) Annullare la registrazione di
vCenter in VSI 3) Ripetere la registrazione di
vCenter in VSI
4) Applicare la best practice dell'host
Additional Information
Un'ulteriore nota da prendere in considerazione. Durante la nuova registrazione di vCenter all'interno di VSI, l'indirizzo IP errato potrebbe essere associato al FQDN di vCenter a causa di una scheda HA configurata per l'host vCenter. In questo caso, l'adattatore HA è stato aggiunto dopo la registrazione VSI originale. Quando è stato effettuato il tentativo di nuova registrazione, è stato ricevuto un errore "Incorrect Password". Dopo un'analisi, è stato rilevato che VSI associava la scheda HA come scheda di rete principale per l'host vCenter che causava l'errore della password. L'adattatore HA è stato rimosso dall'host e la nuova registrazione è stata completata correttamente.
Etkilenen Ürünler
PowerStoreMakale Özellikleri
Article Number: 000184245
Article Type: Solution
Son Değiştirme: 22 Ağu 2024
Version: 3
Sorularınıza diğer Dell kullanıcılarından yanıtlar bulun
Destek Hizmetleri
Aygıtınızın Destek Hizmetleri kapsamında olup olmadığını kontrol edin.