Dell Hardware Diagnostics Service (UK and Europe only)

Summary: Thank you for inquiring about our Dell Depot Diagnostic services.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When you book this service, Dell-certified technicians professionally diagnose your system and contact you with repair costs before proceeding.

The entire process should take 12-15 business days once you ship your system back to Dell within 24 hours of receiving your prepaid box.

 

Note: * Service only available for Mainland UK, France, and Germany (exclusions below )

Cause


 

Door to door support what happens next?

  • You are contacted to arrange the collection date of your system. If you are not available at the time of scheduled pickup, the courier leaves a label with instructions for you to arrange another collection date.
  • Follow the below 'Get ready' instructions and send your system to Dell.
  • Once received at the Dell repair facility, a certified Dell Technician diagnoses your issue and can recommend a repair solution.
 

Repairing your computer

  • A Dell representative makes three attempts to contact you at your specified email and/or your contact number/s provided with the details of the repair required to fix your system and the cost of the repair.
  • Once payment has been received, your system will be repaired and returned to you.
  • If you do not want to proceed with the repair, your system is returned unrepaired without further charge.  Dell's initial diagnostics service fee is nonrefundable.
 

Get ready, before you pack your computer

  • Ensure to back up your data and remove any confidential or proprietary information as the Dell Repair Center may have to reinstall a copy of your original operating system during the repair resulting in data loss.
  • Ensure to remove or disable the computer password, failure to remove the password could prevent the repair center from completing the repair and delay returning the system.
  • Remove accessories except your AC-Adapter.
  • Do not ship memory cards, flash drives, CD drives, or any other external device.
  • Remove accessories except your power adapter.  Dell Technologies recommends that you include your power adapter in the box with your personal computer.

 

NOTE: Dell reserves the right to use refurbished parts and turnaround time is subject to parts availability. Dell provides a 90-day guarantee on the replaced parts.

 

Resolution

Service Exclusions

* Please note, this service is not available for the below locations in the United Kingdom and France:
United Kingdom: JERSEY, GUERNSEY, STORNOWAYISLE OF LEWIS, ISLE OF HARRIS, ISLE OF SCALPAY, ISLE OF NORTH UIST, ISLE OF BENBECULA, ISLE OF SOUTH UIST, ISLE OF BARRA, GAIRLOCH, ACHNASHEEN, GARVE, ARDGAY, ULLAPOOL, LAIRG, ROGART, KYLE, ISLE OF SKYE, PORTREE, PLOCKTON, STROME FERRY, STRATHCARRON, ISLE OF ARRAN, ISLE OF CUMBRAE, MILLPORT, KINBRACE, HALKIRK, FORSINARD, THURSO, KIRKWALL, STROMNESS, ORKNEY, ISLE OF GIGHA, ISLE OF ISLAY, ISLE OF JURA, ISLE OF COLONSAY, ISLE OF MULL, ISLE OF IONA, ISLE OF TIREE, ISLE OF COLL, ACHARACLE, GLENFINNAN, LOCHAILORT, MALLAIG, ISLE OF EIGG, ISLE OF RUM, ISLE OF CANNA, SHETLAND, ISLE OF MAN
France: CORSICA

Article Properties
Article Number: 000132670
Article Type: Solution
Last Modified: 19 Apr 2026
Version:  11
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