Avamar: il backup Solaris non riesce con errore "code12: Not enough space"

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

说明

SINTOMI

Durante il backup di un client Solaris vengono registrati i seguenti avvisi 
2020-03-13 01:10:07 avtar Warning <6028>: Failed to run '/usr/bin/locale' code 12: Not enough space 2020-03-13 01:10:07 avtar Warning <6515>: Failed to get locale information - code 12: Not enough space 
Il backup viene completato ma è possibile che sia presente uno script di post-backup che tenta l'esecuzione sul computer con esito negativo generando lo stesso avviso "code 12: Not enough space". Il backup terminerà con un errore e verrà contrassegnato come "Failed".
2020-03-13 01:10:16 avtar Warning <6028>: Failed to run '/opt/AVMRclnt/etc/scripts/post-script.sh' code 12: Not enough space 2020-03-13 01:10:16 avtar Error <7001>: Exiting avtar with run-at-end script failure 12 

CAUSA

In Solaris e Oracle, "Not enough space" significa che il computer sta esaurendo la memoria virtuale. 
Ciò può essere segno di uno spazio di swapping insufficiente.

La regola generale prevede che lo spazio di swapping disponibile debba corrispondere al 100-200% della memoria fisica, ma tutto dipende dalla versione del sistema operativo.


RISOLUZIONE

Sul backup client, verificare l'area di swapping e la quantità di memoria fisica installata. Durante il backup, in genere i requisiti delle risorse di sistema aumentano a livelli normalmente non registrati in altri scenari di produzione. 

Per risolvere il problema, fare in modo che l'amministratore del computer client aggiunga al computer la quantità di spazio di swapping consigliata.

受影响的产品

Avamar

产品

Avamar, Avamar Client, Avamar Server
文章属性
文章编号: 000023365
文章类型: How To
上次修改时间: 18 5月 2021
版本:  3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。