NetWorker vProxy:备份失败并显示 HTTP 状态 401“HTTP Get request failed to download config file”
摘要: NVP - vProxy 备份失败,并显示“HTTP Get request failed to download config file” HTTP Status code:401.
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
将 vProxy 新部署到新的 vCenter Server。
NetWorker VMware Protection (NVP) 集成正在与 vProxy 应用装置一起配置。由于配置文件下载,虚拟机 (VM) 备份无法初始化。 vProxy 备份会话日志显示:
NetWorker VMware Protection (NVP) 集成正在与 vProxy 应用装置一起配置。由于配置文件下载,虚拟机 (VM) 备份无法初始化。 vProxy 备份会话日志显示:
...
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: 127] HTTP Get request failed to download config file '[Datastore_Name] VM_Folder_Name/VM_Name.vmx" using URL "https://vCenter_Server_Name/folder/VM_Folder_Name/VM_Name.vmx?dcPath=DC_Path&dsName=Datastore_Name".'. HTTP Status code: 401.
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: 127] HTTP Get request failed to download config file '[Datastore_Name] VM_Folder_Name/VM_Name.vmx" using URL "https://vCenter_Server_Name/folder/VM_Folder_Name/VM_Name.vmx?dcPath=DC_Path&dsName=Datastore_Name".'. HTTP Status code: 401.
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: 127] HTTP Get request failed to download config file '[Datastore_Name] VM_Folder_Name/VM_Name.vmx" using URL "https://vCenter_Server_Name/folder/VM_Folder_Name/VM_Name.vmx?dcPath=DC_Path&dsName=Datastore_Name".'. HTTP Status code: 401.
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: 127] Failed to download VM config file "[[Datastore_Name] adc64e5e-30e0-12b6-f413-e4434b931070/VM_NAME.vmx" into saveset file "vm-xxx-config-file-0.cfg".
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: 127] Failed to initialize Backup Descriptor.
...
原因
用于注册 vCenter 资源(NSR 虚拟机管理程序)的 VMware View 帐户未分配给包含执行备份操作所需的最低权限的角色。
解决方案
查看 vCenter 角色权限,以确保其具有 NVP 解决方案所需的最低权限。所需的最低用户角色权限记录在 Dell NetWorker VMware 集成指南的“创建专用 vCenter 用户帐户和 EMC 备份和恢复角色”部分中。 要确认缺少 vCenter 用户帐户的权限,可以使用 ProxyHC 应用工具:
NVP-vProxy:如何在 vProxy
应用装置上使用运行状况检查工具 ProxyHC用于确认权限的语法为:./ProxyHC perm
NVP-vProxy:如何在 vProxy
应用装置上使用运行状况检查工具 ProxyHC用于确认权限的语法为:./ProxyHC perm
受影响的产品
NetWorker产品
NetWorker文章属性
文章编号: 000172309
文章类型: Solution
上次修改时间: 15 11月 2023
版本: 3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。