Dell EMC Unity:无法在使用已配置的代理的情况下获得技术公告(用户可更正)
摘要: 收到技术公告时出错
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
尝试从 Unisphere 检索技术公告时,会生成以下错误消息:
There was an error when retrieving catalog from Dell EMC through configured proxy (Error Code:0x6400bda)'
EMCSystemLogFile.log 显示以下内容:
2021-01-28T17:09:09.974Z" "xxx_spb@APM00123456789" "Neo_CEM" "17037" "local/admin" "WARN" "14:380012" :: "Failed to get technical advisory with configured proxy http://proxy.FQDN.com:8080." :: Category=User Component=EmcSupportServices TimeZone=UTC
用于检查与代理服务器的连接的 curl 命令失败:
# curl -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
Hostname was NOT found in DNS cache
Could not resolve host: colu.emc.com
Closing connection 0
curl: (6) Could not resolve host: colu.emc.com
将代理服务器添加到 curl 命令的操作成功。
# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:"-v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1... (proxy server IP)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive
<--snip-->
(请参阅注释中的完整输出)
There was an error when retrieving catalog from Dell EMC through configured proxy (Error Code:0x6400bda)'
EMCSystemLogFile.log 显示以下内容:
2021-01-28T17:09:09.974Z" "xxx_spb@APM00123456789" "Neo_CEM" "17037" "local/admin" "WARN" "14:380012" :: "Failed to get technical advisory with configured proxy http://proxy.FQDN.com:8080." :: Category=User Component=EmcSupportServices TimeZone=UTC
用于检查与代理服务器的连接的 curl 命令失败:
# curl -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
Hostname was NOT found in DNS cache
Could not resolve host: colu.emc.com
Closing connection 0
curl: (6) Could not resolve host: colu.emc.com
将代理服务器添加到 curl 命令的操作成功。
# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:"-v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1... (proxy server IP)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive
<--snip-->
(请参阅注释中的完整输出)
原因
在这种情况下,客户不允许直接访问 DNS 服务器,只能使用代理服务器来退出。 出现此问题的原因是:在 Unity 与代理服务器之间的数据传输完成之前,colu.emc.com 与代理服务器之间的连接已关闭。 这似乎是由于 curl 处理连接的方式造成的。
解决方案
修复
此问题的修复将包含在未来的 Dell EMC Unity OE 版本中。 请查看此知识库文章以了解更新内容。
解决办法
在发布可修复此问题的代码之前,请勿使用代理服务器检索技术公告或为 Unisphere 设置临时旁路来绕过问题。
此问题的修复将包含在未来的 Dell EMC Unity OE 版本中。 请查看此知识库文章以了解更新内容。
解决办法
在发布可修复此问题的代码之前,请勿使用代理服务器检索技术公告或为 Unisphere 设置临时旁路来绕过问题。
其他信息
将“代理服务器 URL”添加到 curl 命令时,它会成功:
# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1... (proxy server IP)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive
>
< HTTP/1.1 200 Connection established
<
* Proxy replied OK to CONNECT request
* successfully set certificate verify locations:
*CAfile: none
CApath: /etc/ssl/certs/
* SSLv3, TLS handshake, Client hello (1):
*SSLv3, TLS handshake, Server hello (2):
*SSLv3, TLS handshake, Certificate (11):
*SSLv3, TLS handshake, Server key exchange (12):
*SSLv3, TLS handshake, Server finished (14):
*SSLv3, TLS handshake, Client key exchange (16):
*SSLv3, TLS change cipher, Client hello (1):
*SSLv3, TLS handshake, Finished (20):
*SSLv3, TLS change cipher, Client hello (1):
*SSLv3, TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
* Server certificate:
* subject: C=US; ST=Texas; L=Round Rock; O=Dell; CN=colu.emc.com
* start date: 2020-08-25 03:21:00 GMT
* expire date: 2022-08-25 03:21:00 GMT
* subjectAltName: colu.emc.com matched
* issuer: C=US; O=Entrust, Inc.; OU=See www.entrust.net/legal-terms; OU=(c) 2012 Entrust, Inc. - for authorized use only; CN=Entrust Certification Authority - L1K
* SSL certificate verify ok.
# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1... (proxy server IP)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive
>
< HTTP/1.1 200 Connection established
<
* Proxy replied OK to CONNECT request
* successfully set certificate verify locations:
*CAfile: none
CApath: /etc/ssl/certs/
* SSLv3, TLS handshake, Client hello (1):
*SSLv3, TLS handshake, Server hello (2):
*SSLv3, TLS handshake, Certificate (11):
*SSLv3, TLS handshake, Server key exchange (12):
*SSLv3, TLS handshake, Server finished (14):
*SSLv3, TLS handshake, Client key exchange (16):
*SSLv3, TLS change cipher, Client hello (1):
*SSLv3, TLS handshake, Finished (20):
*SSLv3, TLS change cipher, Client hello (1):
*SSLv3, TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
* Server certificate:
* subject: C=US; ST=Texas; L=Round Rock; O=Dell; CN=colu.emc.com
* start date: 2020-08-25 03:21:00 GMT
* expire date: 2022-08-25 03:21:00 GMT
* subjectAltName: colu.emc.com matched
* issuer: C=US; O=Entrust, Inc.; OU=See www.entrust.net/legal-terms; OU=(c) 2012 Entrust, Inc. - for authorized use only; CN=Entrust Certification Authority - L1K
* SSL certificate verify ok.
受影响的产品
Dell EMC Unity Family文章属性
文章编号: 000182700
文章类型: Solution
上次修改时间: 08 5月 2026
版本: 4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。