Cloud Disaster Recovery: Windows Server 2019 虚拟机不符合要求,无法在 ESXi 升级后上传到云

摘要: 在 vCenter 和 ESXi 主机升级到 7.0 后,运行客户机操作系统 Windows Server 2019 的虚拟机无法再上传到云。虚拟机出现故障并显示不兼容状态。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

在 Cloud Disaster Recovery 中,允许将虚拟机上传到 AWS 或 Azure 云存储(如果认为它们兼容)。有关兼容性的更多详细信息,请参阅 CDR 简单支持矩阵 和最新的 CDR 发行 说明。

 

对于 Windows 2019,虚拟机被视为最新版本的 CDR 中的合规操作系统。当 VMware 环境从 6.x 升级到 7.x 时,会出现此问题。

 

在低于 7.0 的 VMware 版本中,不提供 Windows 2019 来宾操作系统。解决方法是根据 VMware 知识库 文章 https://kb.vmware.com/s/article/59222 为来宾操作系统选择 Windows 2016。

 

原因

在确定兼容性的过程中,Cloud Disaster Recovery 使用安装在虚拟机上的 vmtools 来查看列出的 osType。升级 VMware 环境后,新的 osType 字符串会导致可以保护的虚拟机开始被标记为不受支持。

 

在新版本的 ESXi 中,VMware 修复了将 2019 虚拟机的操作系统版本作为 2016 或更高版本传递的问题。尽管支持虚拟机,但由于 VMware 以前从未传递过该 2019 osType 字符串,因此不存在筛选器条目。缺少此筛选器条目意味着所传递的新 osType 导致了兼容性失败。

 

在日志中找到的症状:

Many PROTECTION events noting: VM is not compatible - VM protection aborted. Running OS on VM is not compatible with target

 

在 CDR 数据库中,VM 成功时 vm_compatibility_data JSON 字符串中的 osType 值,保护显示“Windows Server 2016 或更高版本(64 位)”:

select * from vm_compatibility where vm_id = "50XXXXXXX-XXXX-XXXX-XXX-XXXXXXXXXXXX" order by creation_time desc limit 1;

id: 6b97ffa9-XXXX-XXXX-XXXX-0de27a34a82b
creation_time: 2021-01-12 16:31:52
vm_id: 50XXXXXXX-XXXX-XXXX-XXX-XXXXXXXXXXXX
vc_id: 2XXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX 
vm_compatibility_data : {"osType":"Microsoft Windows Server 2016 or later (64-bit)","is64bit":true,"disksDetails":[{"bootPriority":0,"sizeInByte":42949672960},{"bootPriority":1,"sizeInByte":85899345920},{"bootPriority":0,"sizeInByte":42949672960}],"freeSpaceRootVolumeInByte":53921234944,"firmware":"bios"}

 

ESXi 更改后,vm_compatibility表中的新条目将显示 osType为“Windows Server 2019 (64-bit)”的vm_compatibility数据:

id: d47ab7ac-XXXX-XXXX-XXXX-3c131cb306a8
creation_time: 2021-01-25 14:32:31 
vm_id: 50XXXXXXX-XXXX-XXXX-XXX-XXXXXXXXXXXX
vc_id: 2XXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX 
vm_compatibility_data : {"osType":"Microsoft Windows Server 2019 (64-bit)","is64bit":true,"disksDetails":[{"bootPriority":0,"sizeInByte":42949672960},{"bootPriority":1,"sizeInByte":85899345920},{"bootPriority":0,"sizeInByte":42949672960}],"freeSpaceRootVolumeInByte":51983851520,"firmware":"bios"} 

 

解决方案

受影响的版本:
19.8 之前的所有版本

 

版本地址:
版本 19.8

 

解决方法:
有适用于特定版本的修补程序:仅限 19.5.0.1(20)、19.5.0.0(24)、19.5.0.2(6) 和 19.6.0.1(27)

如果不是版本 19.5 或无法升级到至少版本 19.8,请向支持部门提交工单,以查看可能的替代方案。

如果运行指定的版本,请打开支持案例以安装热修复程序。

 

受影响的产品

Cloud Disaster Recovery

产品

Avamar, PowerProtect Data Protection Appliance, PowerProtect Software
文章属性
文章编号: 000186175
文章类型: Solution
上次修改时间: 16 7月 2024
版本:  3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。