SRM 4.6:SRM 升级 UI 显示一条消息“某些组件可能未正确升级...”
摘要: SRM 升级 UI 显示错误消息“Some components might not have been upgraded properly due to errors being encountered during the process. 检索日志” 尝试升级时,升级 UI 卡在消息处 “应用程序正在退出时请稍候... 退出完成后,您将被重定向到 SolutionPack UI,以便继续升级” ...
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
前端日志显示错误消息:-
Client received SOAP Fault from server: couldn't get any response from the process in 600000ms... Please see the server log to find more detail regarding exact cause of the failure.
尝试退出维护模式后,UI 随后会显示消息:
Please wait while the application is exiting... Once the exit is complete, you will be redirected to the SolutionPacks UI in order to proceed with their upgrade
原因
前端主机与已升级的其他 SRM 主机之间的通信问题。
解决方案
在遇到此问题的一个环境中,它被确定为不是问题。遵循了以下步骤进行确认。
- 对于在升级 UI 中显示错误的任何服务器,通过 SSH 连接到主机并浏览到目录 /opt/APG/Tools/Update-Manager/X.x/logs(其中 X.x 是主机上的版本号)
- 查看“core-update.log”文件以确认是否有任何模块更新失败
- 然后查看文件“update.status”。此文件显示尝试过的所有模块,其中有多少个成功,以及是否有任何失败。例如:
"modules":{"success":5,"error":0,"total":5}如果所有模块都显示成功,则该主机升级成功。UI 通过 Web 服务网关进行通信,有时由于与网络相关的问题,前端主机无法获得更新。这是用于确认主机上的更新是否完成的手动验证。 - 如果 UI 未退出,并且长时间卡在提示正在退出的消息处,则使用以下命令通过 SSH 连接到前端主机并停止所有服务:
/opt/APG/bin/manage-modules.sh service stop all
- 使用以下命令确保没有 SRM 服务正在运行:
ps -ef | grep java
- 如果在步骤 5 中找到任何服务,请检查其进程 ID (PID),并使用以下命令终止该进程,其中 PID 是所有 SRM 服务关闭时运行的任何进程的进程 ID。
kill -9 PID
- 然后使用以下命令重新启动所有服务:
/opt/APG/bin/manage-modules.sh service start all
- 然后按照升级指南继续执行升级步骤,以更新解决方案包数据块
文章属性
文章编号: 000193511
文章类型: Solution
上次修改时间: 12 5月 2026
版本: 5
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。