OMSA:10.1 不响应 DELL_CM 的 WMI 和 SNMP 查询

摘要: Dell OpenManage Server Administrator 10.1.0 及更高版本不再响应来自六个DELL_CMxxxx类的各种系统资源清册项的直接 WMI 或 SNMP 查询。这是因为戴尔工程部门出于安全和安装包大小限制,决定删除底层的 Inventory Collector (IC) 模块。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

从 Dell OpenManage Server Administrator (OMSA) 10.1.0 及更高版本查询以下类现在会返回空结果:

  • DELL_CMApplication
  • DELL_CMDevice
  • DELL_CMDeviceApplication
  • DELL_CMInventory
  • DELL_CMOS
  • DELL_CMProductInfo

这些类提供各种资源清册信息,例如当前系统组件固件和驱动程序版本、基本操作系统信息等。

原因

由于 OMSA 中剩余的过时版本、较大的安装大小和带宽限制以及安全考虑,戴尔工程部门决定不再捆绑 Inventory Collector (IC) 模块。早些年,IC 主要同时支持 Dell IT Assistant 和 Dell OpenManage Essentials。OMSA 9.5 是捆绑 IC 的最后一个版本。这两种产品均已停止支持,并替换为 Dell OpenManage Enterprise,后者依赖 iDRAC 而不是 OMSA 进行此资源清册。

解决方案

如果使用 OMSA 进行直接 WMI 或 SNMP 编程仍需要这些类的清单数据,请在以下路径中手动下载并安装 IC 模块。然后应启用并重新启动 OMSA 共享服务:

Windows:

  1. 创建文件夹“cm”和”invcol“内 C:\Program Files\Dell\SysMgt\
  2. 下载适用于 Windows 的 IC: https://downloads.dell.com/FOLDER07847532M/1/invcol_8YPK7_WIN64_21_12_200_1196_A00.exe
  3. 将下载重命名为 invcol.exe ,然后移至 C:\Program Files\Dell\SysMgt\cm\invcol\
  4. 重新启动 DSM SA 共享服务并等待最多 10 分钟,以便 IC 完成其初始资源清点。

Linux:

  1. 下载适用于 Linux 的 IC: https://downloads.dell.com/FOLDER07847525M/1/invcol_8YPK7_LN64_21_12_200_1196_A00.BIN
  2. 重命名为 invcol 并移至 /opt/dell/srvadmin/sbin/lx64/
  3. 在 shell 提示符下,运行命令: 
srvadmin-services restart

受影响的产品

OpenManage Server Administrator, Dell OpenManage Server Administrator Version 10.1.0.0, OEMR R240, OEMR R250, OEMR XE R250, OEMR R260, OEMR XE R260, OEMR R340, OEMR R350, OEMR XE R350, OEMR R360, OEMR XE R360, OEMR R440, PowerEdge XR2, OEMR R450 , OEMR R540, OEMR R550, OEMR R5500, OEMR R640, OEMR XL R640, OEMR R6415, OEMR R650, OEMR R650xs, OEMR R6515, OEMR R6525, OEMR R660, OEMR XL R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR XL R740, OEMR R740xd, OEMR XL R740xd, OEMR R740xd2, OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR XL R760, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR T140, OEMR T150, OEMR T340, OEMR T350, OEMR T360, OEMR T440, OEMR T550, OEMR T560, OEMR T640, OEMR XL T640, OEMR XL R240, OEMR XL R340, OEMR XL R660xs, OEMR XL R6615, OEMR XL R6625, OEMR XL R760xs, OEMR XL R7615, OEMR XL R7625, OEMR XR11, OEMR XR12, Poweredge C4140, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640, PowerEdge HS5610, PowerEdge HS5620, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640, PowerEdge XE2420, PowerEdge XE7100, PowerEdge XE7420, PowerEdge XE7440, PowerEdge XE8545, PowerEdge XE8640, PowerEdge XE9640, PowerEdge XE9680, PowerEdge XE9680L, PowerEdge XR11, PowerEdge XR12 ...
文章属性
文章编号: 000193542
文章类型: Solution
上次修改时间: 12 5月 2026
版本:  7
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。