Dell EMC Unity:升级到版本 5.1.2 时使用连续可用性可能导致 SP 崩溃(用户可纠正)

摘要: 在 SMB 共享上启用连续可用性 (CA) 时,升级到版本 5.1.2 可能会导致 SP 崩溃并且 SP 进入服务模式。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

升级后,SP 可能会崩溃并重新启动进入服务模式。用户无法在服务模式中删除 SP。

原因

此问题与 SMB 的连续可用性功能有关。在少数情况下,如果客户在其 SMB 共享上选择了连续可用性,并且这些共享上有大量打开的文件句柄(超过 97 个打开的句柄),使得新变量 (phMaxTimeout) 的值过高,从而导致崩溃和服务模式。

解决方案

修复:
升级到 Dell EMC Unity 操作环境 (OE) 版本 5.1.3 以解决此问题。

解决方法:
如果您已升级并遇到此问题,请联系 Dell EMC 技术支持或您的授权服务提供商,并引用此知识库文章 ID。

如果您尚未升级到版本 5.1.2,并且无法升级到 5.1.3,则必须在升级之前在所有 SMB 共享上禁用连续可用性。
  1. 在 Unisphere 中,选择 STORAGE 标题,然后单击 File。选择 SMB Shares 选项卡。
  2. 单击每个 SMB 共享并选择 Properties(选择共享后单击铅笔图标)。
  3. Properties 对话框中,单击 Advanced 选项卡。
  4. 确保 Continuous Availability 已关闭。
您还可以使用 uemcli 通过以下命令检查和禁用连续可用性:
  • uemcli -no /stor/prov/fs/cifs show -filter "Name","Availability enabled" -output csv
  • uemcli -no /stor/prov/fs/cifs -id set -enableContinuousAvailability no
使用以下命令禁用所有 VDM 的持久句柄 (DH):
  • svc_nas ALL -param -f cifs -m smb2.defaultFdhv2Timeout -v 0
提醒:在可以升级到 5.1.3 之前,请一直保留这些设置。届时可以重新激活连续可用性。

受影响的产品

Dell EMC Unity
文章属性
文章编号: 000195010
文章类型: Solution
上次修改时间: 12 5月 2026
版本:  8
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。