PowerEdge:远程桌面许可证弹出窗口警告会话已断开连接
摘要: 当用户连接到远程桌面会话主机时,他们会收到一个弹出窗口,指示其会话将在 60 分钟内断开连接。
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
在用户建立与远程桌面会话主机的连接后不久,将显示以下弹出窗口:
图 1:一个弹出窗口,指示远程桌面会话将在 60 分钟内断开连接。
用户的远程桌面会话确实在 60 分钟后断开连接。
原因
此问题有多种可能的原因,其中最常见的是以下两种:
- 远程桌面会话主机服务器使用“每用户”许可,并且位于工作组中。
- 远程桌面会话主机服务器使用“每用户”许可,并且位于域中,但受影响的用户登录到服务器上的本地帐户,而不是域帐户。
解决方案
原因 1:远程桌面会话主机服务器使用。每用户许可,位于工作组中。
正如 Microsoft 在此处 和其他位置中所述,每用户许可在工作组中无法正常工作。要使用每用户许可,需要 Active Directory (AD) 域。如果环境中已存在域,则会话主机应成为域成员,此后“每用户”许可功能正常运行。
如果环境中不存在 AD 域,有两个选项可用于解决问题:
-
这是迄今为止最简单的选项。按照 如何将 Windows 远程桌面 CAL 从每用户转换为每设备中的步骤,将已安装的每用户客户端访问许可证 (CAL) 转换为每设备 CAL,反之亦然。如该文章中所述,还需要将部署的许可模式从“每用户”更改为“每设备”。
-
通过将环境中的服务器(最好 不是 会话主机)提升为域控制器,然后将会话主机加入域来创建 AD 域。这不是一个微不足道的过程,该域需要持续管理。
原因 2:会话主机服务器使用。每用户许可,位于域中,但受影响的用户登录到本地服务器帐户而不是域帐户。
是否发生这种情况可以通过运行
解决原因 2 非常简单:确保用户在 AD 域中拥有帐户,并在连接到远程桌面会话主机时登录到这些帐户。提示输入凭据时,在
whoami 从用户远程桌面会话中的命令提示符发出命令。输出位于 domain\username 格式。如果输出的域部分等于会话主机服务器的名称,则用户将登录到本地帐户。
解决原因 2 非常简单:确保用户在 AD 域中拥有帐户,并在连接到远程桌面会话主机时登录到这些帐户。提示输入凭据时,在
domain\user 格式实现了这一点。
受影响的产品
Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows Server 2025, OEMR R440, OEMR R450, OEMR R540, OEMR R550, OEMR R5500, OEMR R640, OEMR XL R640, OEMR R6415, OEMR R650, OEMR R650xs
, OEMR R6515, OEMR R6525, OEMR R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR R740xd, OEMR R740xd2, OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR XR4510c, OEMR XR4520c, OEMR XR5610, OEMR XR8610t, OEMR XR8620t, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge XR4510c, PowerEdge XR4520c, PowerEdge XR5610, PowerEdge XR8610t, PowerEdge XR8620t
...
文章属性
文章编号: 000200873
文章类型: Solution
上次修改时间: 16 7月 2025
版本: 5
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。