SDBG 服务器启动时 PowerFlex SDS 崩溃

摘要: SDS 无法启动。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

情况说明

SDS 分离,在尝试启动时,它会反复崩溃,其中怀疑的问题是 SDBG 服务器启动。

症状

Repeated panic on startup attempt stack trace: 

  08/03 20:56:58.388914 Panic in file /data/build/workspace/ScaleIO-Common-Job/src/tgt/tgt.c, line 303, function main, PID 50379.Panic Expression rc== 65 PANIC_ID_tgt_1511773103687.
/opt/emc/scaleio/sds/bin/sds-3.5.1100.107(mosDbg_PanicPrepare+0x13a) [0x93b62a]
/opt/emc/scaleio/sds/bin/sds-3.5.1100.107(main+0x2ce) [0x4cd18e]
/lib64/libc.so.6(__libc_start_main+0xf5) [0x7fb153287555]
(...)
08/03 21:13:59.562976 Panic in file /data/build/workspace/ScaleIO-Common-Job/src/tgt/tgt.c, line 303, function main, PID 123025.Panic Expression rc== 65 PANIC_ID_tgt_1511773103687.
/opt/emc/scaleio/sds/bin/sds-3.5.1100.107(mosDbg_PanicPrepare+0x13a) [0x93b62a]
/opt/emc/scaleio/sds/bin/sds-3.5.1100.107(main+0x2ce) [0x4cd18e]
/lib64/libc.so.6(__libc_start_main+0xf5) [0x7f72ec9c5555]

 

在客户站点上单次遇到此问题时,由于日志轮换,没有 SDS 跟踪。

 

 

影响

系统将在单点故障中运行,如果出现其他组件故障,客户将遇到 DU 情况。

原因

未知 - 可疑的根本原因是已实施的特殊 SELinux 规则,但是,这并不确定,仅被确定为可能的根本原因,因为这是客户系统上唯一的异常因素。
SDBG 服务器启动问题也可能是由于组件的 SDBG 侦听端口被系统上的另一个进程使用、资源不足以及其他与作系统相关的问题引起的。 

解决方案

解决方法

重新启动 SDS 主机 - 重新启动主机将允许 SDS 正确启动。

受影响的版本

未知 - 问题发生在版本 3.5.1.1 上,但尚不清楚哪些版本受到影响。 

已修复问题的版本

此问题尚未修复。

受影响的产品

PowerFlex Software, VxFlex Product Family, VxFlex Ready Node, ScaleIO Ready Node-PowerEdge 13G, Ready Node Series
文章属性
文章编号: 000203235
文章类型: Solution
上次修改时间: 15 5月 2026
版本:  5
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。