Avamar:客户端管理器中的错误 —“The request has invalid CSRF token”和“TypeError:Data is undefined”
摘要: 打开 Avamar Client Manager 报告错误:“请求具有无效的 CSRF 令牌”和“TypeError:Data is undefined”
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
情景:
Tomcat 已重新启动。
浏览器缓存已清除。
登录到客户端管理器并导航到选项卡 work/ 。
尝试从客户端管理器注销时,会看到以下错误。

每当客户端管理器重新打开时,不会显示登录提示,并且会看到相同的错误。
有关 Avamar 的信息似乎已丢失。在服务器摘要中,我们看到“未找到数据”。
以下是 ACMTrace 日志中显示的错误:
2022-07-06 15:44:43,340 WARN [ajp-nio-0:0:0:0:0:0:0:1-8509-exec-9]-common.NotificationAction: Notification to action invalidCSRF
022-07-06 15:44:43,342 ERROR [ajp-nio-0:0:0:0:0:0:0:1-8509-exec-9]-filters.AuthenticationFilter: The request has invalid CSRF token, rejecting the request 2022-07-06 15:44:43,633 WARN [ajp-nio-0:0:0:0:0:0:0:1-8509-exec-8]-common.NotificationAction: Notification to action invalidCSRF
2022-07-06 15:44:43,635 ERROR [ajp-nio-0:0:0:0:0:0:0:1-8509-exec-8]-filters.AuthenticationFilter: The request has invalid CSRF token, rejecting the request
2022-07-06 15:49:31,177 INFO [localhost-startStop-2]-listeners.ContextLauncher: Servlet Context Destroyed.
2022-07-06 15:49:34,384 INFO [localhost-startStop-2]-listeners.ContextLauncher: Servlet Context Destroyed.
2022-07-06 15:52:38,931 INFO [localhost-startStop-1]-listeners.ContextLauncher: Servlet Context Launched
原因
浏览器不允许使用 Avamar Activation Manager 的 Cookie。
解决方案
在浏览器中允许 Avamar cookie。示例说明如下,但如果有疑问,请参阅供应商文档。
Chrome:
Chrome:
-
打开 Chrome 设置 。
-
滚动到底部,然后单击 Advanced (高级)。
-
在“隐私和安全”部分中,单击“内容设置”按钮。
-
单击 Cookie 。
-
在 允许 旁边,单击 添加 。键 入 [*.]avamarfqdn (例如:*.avamarlab。com)并单击“Add”。
-
在 所有 cookie 和站点数据 下,搜索 avamar fqdn,并删除所有与 avamarfqdn 相关的条目。
-
重新加载 Chrome 并登录到 avamar Client Manager 页面。
Firefox:
-
转至 Firefox 的 Preferences > Privacy and Security Menu 。
-
在 History 部分中,从下拉菜单中选择“Use custom settings for history”。
-
单击 Exceptions and whitelist avamar FQDN (示例 测试)。avamar。com)
-
向下滚动到 Site Data (站点数据),然后单击它旁边的 Settings (设置)。
-
搜索“avamar fqdn”并删除所有显示的条目。
-
重新加载 Firefox 并尝试登录到 avamar Client Manager 页面。
文章属性
文章编号: 000204692
文章类型: Solution
上次修改时间: 13 7月 2023
版本: 2
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。