Avamar:由于资源利用率过高而超时,SQL 备份失败
摘要: 当 SQL 客户端系统遇到高 CPU 和内存利用率时,Avamar SQL 备份可能会失败并显示超时和 I/O 错误。当其他服务器进程占用关键资源时,会出现此问题,这会阻止 Avamar 备份进程成功完成。
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
- SQL 备份在 Avamar Administrator UI 或 Avamar 用户界面 (AUI) 活动监视器中失败或异常终止。
- SQL 备份作业看似完成了数据传输,但在 SQL 处理过程中失败。
- SQL 客户端日志报告与 I/O 和超时相关的错误。
- 在备份窗口期间,SQL 客户端上的 CPU 和 RAM 使用率始终保持高位。
SQL 备份日志(在 SQL 客户端上)中显示以下错误:
C:\Program Files\avs\var\SxOMxxxxx_SQL1_hpxxn_uxxmdb_test_SQL_Schedule-test_SQL_Backups-1722556800070-3006-SQL.log
2024-08-02 08:20:38 avsql Info <6688>: Process 17036 (C:\Program Files\avs\bin\avtar) finished (code 0: success)
2024-08-02 08:20:38 avsql Info <6446>: SQL VDI transfer of 'SxOMxxxxx\SQL1/hpxxn_uxxmdb/f-0.hpxxn_uxxmdb' to 'SxOMxxxxx_SQL1_hpxxn_uxxmdb_test_SQL_Schedule-test_SQL_Backups-1722556800070-3006-SQL' successful
2024-08-02 08:20:38 avsql Error <40258>: sqlconnectimpl_smo::execute Microsoft.SqlServer.Management.Common.ExecutionFailureException: An exception occurred while executing a Transact-SQL statement or batch. ---> System.Data.SqlClient.SqlException: Write on "SxOMxxxxx_SQL1_hpxxn_uxxmdb_test_SQL_Schedule-test_SQL_Backups-1722556800070-3006-SQL" failed: 995(The I/O operation has been aborted because of either a thread exit or an application request.)
A nonrecoverable I/O error occurred on file "SxOMxxxxx_SQL1_hpxxn_uxxmdb_test_SQL_Schedule-test_SQL_Backups-1722556800070-3006-SQL:" 995(The I/O operation has been aborted because of either a thread exit or an application request.).
BACKUP DATABASE is terminating abnormally.
查看 SQL 客户端 任务管理器 中的性能指标后,可以清楚地看到存在显著的 CPU 利用率:
图 1.任务管理器 CPU 利用率
在检查消耗大量 CPU 和 RAM 的进程时,发现还有其他进程使用最大可用资源:
图 2.正在运行的任务管理器进程
原因
当其他服务器进程(如 SQL Server Windows NT 服务或第三方代理)占用大部分可用的 CPU 和 RAM 时,会出现此问题。
高资源利用率会阻止 Avamar 备份进程维护所需的 I/O 操作,从而导致 SQL 备份超时和失败。
解决方案
联系 SQL/Wintel 管理团队,以减少 SQL Server 和其他代理进程对 CPU 和 RAM 的使用。
有关其他信息,请参阅以下文章:
-
资源池“内部”中的系统内存不足,无法运行此查询
(外部链接 - microsoft.com)
-
资源池“default”中的系统内存不足,无法运行此查询。在 SQL
上 (外部链接 - stackoverflow.com)
-
服务器内存配置选项
(外部链接 - microsoft.com)
文章属性
文章编号: 000227635
文章类型: Solution
上次修改时间: 10 6月 2026
版本: 7
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。