Dell NativeEdge:从 v3.0 升级到 v3.1 失败,并显示0x01902004错误

摘要: 当用户将 NativeEdge Orchestrator 从 v3.0 升级到 v3.1 时,可能会观察到0x01902004错误。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

当用户将 NativeEdge Orchestrator 从 v3.0 升级到 v3.1 时,可能会观察到0x01902004错误。用户可以在升级脚本输出中找到以下失败消息。 

OK. Connection can be established!
Splitting upgrade bundle into chunks: /home/user/baobab/.resources/upload/eoBundle_v3.1.0.0.tar.gz Starting to upload the upgrade bundle: /home/user/baobab/.resources/upload/eoBundle_v3.1.0.0.tar.gz
Did not get the expected response while uploading chunk 1418. Received response: no healthy upstream. Error code: 0x019020004 cleaning up temp files

升级服务不时报告就绪情况探测失败,导致升级服务标记为未就绪且不接受流量。结果是区块上传期间失败。 

原因

NativeEdge Orchestrator 升级服务会监视 NATS,以查看其是否可以正常运行。在 v3.1 升级之前,该服务使用 NATS 的 /varz 终结点,该终结点具有相对较大的有效负载。当此调用花费的时间超过预期时,升级服务会将自己标记为“未就绪”,从而导致问题。 

注释

  • 仅当从 v3.0.0.0 升级到 v3.1.0.0 时,才会出现此问题。 
  • 从 v3.1.0.0 升级到未来版本不应出现此问题。 

解决方案

正在重新启动 NativeEdge Orchestrator 虚拟机。在测试中观察到,大多数情况下重新启动虚拟机可以解决问题。

如果重新启动虚拟机无法解决问题,请联系戴尔支持以获取进一步的说明。 

受影响的产品

NativeEdge Solutions
文章属性
文章编号: 000302478
文章类型: Solution
上次修改时间: 01 4月 2025
版本:  1
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。