未安装 Dell Networking OS10 路由
摘要: 问题在于戴尔 S5248F 交换机上的 Broadcom 硬件中未安装新路由。OS10 可以学习新路由,但无法将其安装在 Broadcom 硬件表中。此问题会影响所有平台和所有 OS10 版本,但可以使用交换机的配置或表大于 S5200 的不同平台来缓解。
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
- 收集信息:
- 使用
sosreport用于收集系统日志和硬件表信息的命令。 - 收集拓扑映射和配置详细信息。
hshell -c "l3 info"命令显示表空间是否已用尽。
- 使用
- 识别问题:
- 检查哪些路由不起作用,以及设备是否无法通信。
- 使用
OS10 show命令,您可以在路由表中看到路由。 - 从 OS10 内核,
ping在源和目标之间工作。 - 无法在
defip表hshell命令验证每个 SP 是处于正常模式还是修复模式。- 对于 IPv4,
hshell -c "´l3 defip show"可用于检查路由条目。 - 对于 IPv6,
hshell -c "l3 ip6route show"可用于检查路由条目。 - 使用以下命令检查当前表的使用情况:
hshell -c "l3 info"命令验证每个 SP 是处于正常模式还是修复模式。
- 对于 IPv4,
- 您还可以将
journalctl查找以下条目的输出。
//======== [ROUTE:HAL-RT-DR], Error: hal_fib_route_add vrf_id: 8, prefix: 201.54.14.249, prefix_len: 32, hal_err: -1 (Failure) base_nas[err]: [ev_log_t_SAI_ROUTE:Switch Id: 0], Failed to add route in Unit 0. Err: Table full. base_nas[err]: [ev_log_t_SAI_ROUTE:Switch Id: 0], Route Add failed //========
- 表使用情况计算如下:
Example: ip6 routes – 12 (show ipv6 route summary including all VRF) ipv4 routes - 12 (show ip route summary including all VRF) total routes = 36 = ip6-routes*2 + ip4-routes <------ Note: IPv6 takes two entries. l3 info shows the number of used/total-entries hosts/route entries. //======= OS10#system "sudo hshell -c 'l3 info'" hosts : 12 / 147456 routes : 31 / 32768 nexthops : 9 / 65536 ecmp_groups : 0 / 4096 overlay_ecmp_defrag : 0 underlay_ecmp_defrag : 0 //=======
原因
- 根本原因:
- 此问题可能发生在任何 OS10 版本上。
- 此问题是由于 Broadcom 硬件表已满,导致无法添加新路由。
- 证明文件:
- 有关详细的命令用法和硬件限制,请参阅最新的 Dell SmartFabric OS10 用户指南。
- S5200 平台的硬件限制:

解决方案
- 由于存在硬件限制,因此无意在 OS10 代码中修复此问题。使用下面的一些选项来解决此限制
- 使用以下命令检查当前硬件配置文件,并在限制范围内有足够的路由和主机。
Note: The command was taken from s5248f. OS10# show hardware forwarding-table mode all Mode default scaled-l2 scaled-l3-routes scaled-l3-hosts L2 MAC Entries 163840 294912 32768 98304 L3 Host Entries 147456 16384 16384 212992 L3 Route Entries 32768 32768 131072 98304
- 使用命令监视表空间
"l3 info"在hshell菜单中进行更改。 - 使用不同的配置来禁止交换机中安装的不必要的路由或主机条目。
受影响的产品
PowerSwitch, SmartFabric OS10 Software文章属性
文章编号: 000322394
文章类型: Solution
上次修改时间: 28 1月 2026
版本: 3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。