Dell NativeEdge:蓝图部署中的性能问题

摘要: 蓝图部署花费的时间超过预期,并且 CPU 利用率更高,并且在 Fluent bit Pod 上出现性能问题。本文介绍如何优化性能或解决此问题,以增加整体蓝图处理时间。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

在蓝图部署期间,Fluent Bit Pod 遇到高 CPU 利用率,接近其定义的 CPU 限制。这种使用量的增加会减慢整个蓝图部署过程的速度。

kubectl top po -A --containers | grep fluent

NAMESPACE   POD NAME                  CONTAINER NAME   CPU (cores)   MEMORY (bytes)
hzp         fluentbit-btz2g           fluentbit        999m          43Mi

CPU Usage: 999m means the container is using 999 millicores, which is nearly 1 full CPU core
 
提醒:要运行 kubectl top 命令,您必须安装 Metrics Server。

原因

此问题的根本原因是未正确设置流畅位 Pod 上的 CPU 利用率(包括资源限制)。

解决方案

您可以根据资源可用性和负载优化 CPU 限制。增加 中的 CPU 限制 Daemonset 流利的位。流畅位 Pod 由 Deamon set 因此,您不能直接编辑 pod,并且必须以流畅位更改 CPU 限制值 Daemonset

kubectl edit daemonset fluentbit -n hzp
    spec:
      containers:
      - env:
        - name: AWS_ACCESS_KEY_ID
          valueFrom:
            secretKeyRef:
              key: AWS_ACCESS_KEY_ID
              name: eo-management-seaweedfs-s3-secret
        - name: AWS_SECRET_ACCESS_KEY
          valueFrom:
            secretKeyRef:
              key: AWS_SECRET_ACCESS_KEY
              name: eo-management-seaweedfs-s3-secret
        - name: K8S_NODE_NAME
          valueFrom:
            fieldRef:
              apiVersion: v1
              fieldPath: spec.nodeName
        - name: FLUENT_FOWARD_HOST
          value: localhost
        - name: FLUENT_FOWARD_PORT
          value: "80"
        image: harbor-dell.default.svc.cluster.local/renbaobabga/fluent/fluent-bit:3.2.6
        imagePullPolicy: IfNotPresent
        name: fluentbit
        ports:
        - containerPort: 8080
          protocol: TCP
        resources:
          limits:
            cpu: "1" >> change it to number depends on your env load and resource allocation  


CPU:“1”,将其更改为数字取决于您的环境负载和资源分配。 

 

提醒:上述更改需要一些时间来重新创建流畅位 Pod。


通过运行以下命令验证 CPU 限制更改: kubectl describe po fluentbit-btz2g -n hzp
通过运行以下命令验证 CPU 使用情况: kubectl top po -A --containers | grep fluent

受影响的产品

NativeEdge Solutions, NativeEdge
文章属性
文章编号: 000329136
文章类型: Solution
上次修改时间: 17 2月 2026
版本:  3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。