PowerProtect:重置忘记或锁定的密码 |PPDM系列

摘要: 如果忘记了 PowerProtect Data Manager (PPDM) 用户界面的“管理员”或用户密码,或者帐户由于反复的无效登录尝试而被锁定,请按照以下步骤使用 CLI 工具(版本 19.19 及更高版本)重置密码。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

受影响的产品:

  • PowerProtect Data Manager(版本 >=19.19)

症状:

  • 无法使用“管理员”(或用户)帐户登录 PPDM UI
  • 帐户因多次尝试使用无效密码而被锁定
  • 登录错误出现在”/var/log/brs/dp-common-iam/keycloak.log",例如
    • ... error="user_temporarily_disabled",... ....  username="admin"

原因

在多次登录尝试失败后,帐户将被锁定。
在版本 19.19 中,PPDM 使用 客户身份和访问管理 (CIAM) 服务,这些服务将用户凭据存储在 Keycloak/PostgreSQL (而不是 ElasticSearch 或密码箱)中。对密码进行哈希处理并集中管理。

解决方案

1.获取组件令牌:

export TOKEN=$(curl -XPOST -H 'X-Component-Name: aaa-client' https://localhost:9090/token  -d '{"grant_type": "client_credentials", "scope": "aaa"}' -H "Content-type: application/json" -k --cacert /etc/ssl/certificates/rootca/rootca.pem --cert /etc/ssl/certificates/component/component.pem --key /etc/ssl/certificates/component/componentkey.pem | python3 -c "import sys, json; print(json.load(sys.stdin)['access_token'])")

2.检索用户信息:

  • 使用下面的“curl”命令:
    • 取代 <username> 使用锁定的帐户名称(例如, admin):
      • 示例: username=lionel, then .../local-accounts?username=lionel
curl -s -k -H "Authorization: Bearer $TOKEN" -H "Content-Type: application/json" -X GET  https://<ip-addres>:9876/powerprotect-iam/rest/v2/local-accounts?username=<username>

示例: 

admin@dpswan192:~> curl -s -k -H "Authorization: Bearer $TOKEN" -H "Content-Type: application/json" -X GET  https://192.168.0.100:9876/powerprotect-iam/rest/v2/local-accounts?username=lionel | json_pp
{
   "last_login_timestamp" : "",
   "last_name" : "F",
   "first_name" : "Lionel",
   "is_password_change_required" : false,
   "data_center" : null,
   "is_builtin" : false,
   "mfa_service_id" : null,
   "email_address" : "test@test.com",
   "is_locked" : true,
   "role_ids" : [
      "f80d7379-4d4c-4b62-abcc-7e80a31e6869"
   ],
   "is_enabled" : true,
   "id" : "97963af5-36d6-470f-8688-63be46c048af",
   "mfa_alias" : "ryanf@d623f30c-b624-4a65-a714-d8391acab9d9",
   "is_mfa_bypass" : false,
   "uid" : 100000004,
   "description" : null,
   "group_id" : "",
   "password_expiration_timestamp" : null,
   "created_by" : "",
   "last_password_change_timestamp" : "2025-05-02T20:41:27Z",
   "created_timestamp" : "2025-05-02T20:38:49Z",
   "role_id" : "f80d7379-4d4c-4b62-abcc-7e80a31e6869",
   "username" : "lionel"
}

从上述有效负载中获取“ID”值,并在步骤 3 中使用它:

3. 解锁并重置密码。

在下面的命令中输入步骤 2 中的 “id” 编号,替换 <user-id> (“/powerprotect-iam/rest/v2/local-accounts/<user ID>”:请参阅下面的示例)

  • 该命令将更新用户帐户,如下所示:
    • 解锁用户
    • 设置临时密码: Changeme@123
    • 下次登录时强制更改密码
curl -s -k -H "Authorization: Bearer $TOKEN" -H "Content-Type: application/json" -X PATCH -d '{"is_enabled":true,"is_password_change_required":true,"password":"Changeme@123"}' https://192.168.0.100:9876/powerprotect-iam/rest/v2/local-accounts/<user ID>

使用 “ID” 表单的示例 步骤2.:

curl -s -k -H "Authorization: Bearer $TOKEN" -H "Content-Type: application/json" -X PATCH -d '{"is_enabled":true,"is_password_change_required":true,"password":"Changeme@123"}' https://192.168.0.100:9876/powerprotect-iam/rest/v2/local-accounts/97963af5-36d6-470f-8688-63be46c048af

4.登录并更改密码。

  •  使用以下命令登录 PPDM UI Changeme@123。系统将提示您设置新密码。 

5.从环境中移除组件令牌。

unset TOKEN

受影响的产品

PowerProtect Data Manager
文章属性
文章编号: 000354052
文章类型: Solution
上次修改时间: 22 12月 2025
版本:  4
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